Vagrant 'paver devstack lms' Servidor de inicio: el command "python setup.py egg_info" ha fallado con el código de error 1

Estoy tratando de instalar un edx devstack y estoy teniendo algunos problemas. Encontré esta publicación

Cómo reparar el error de actualización de los requisitos de python (twig principal): combinación de la function SSO

Pero no funcionó para mí. Cuando bash iniciar el server, obtengo el siguiente error:

dxapp@precise64:~/edx-platform$ paver devstack studio ---> pavelib.servers.devstack ---> pavelib.prereqs.install_prereqs ---> pavelib.prereqs.install_ruby_prereqs Ruby prereqs unchanged, skipping... ---> pavelib.prereqs.install_node_prereqs Node prereqs unchanged, skipping... ---> pavelib.prereqs.install_python_prereqs pip install -q --exists-action w -r requirements/edx/pre.txt You are using pip version 6.0.8, however version 7.1.0 is available. You should consider upgrading via the 'pip install --upgrade pip' command. pip install -q --exists-action w -r requirements/edx/github.txt You are using pip version 6.0.8, however version 7.1.0 is available. You should consider upgrading via the 'pip install --upgrade pip' command. Could not find a tag or branch '96e1922348bfe6d99201b9512a9ed946c87b7e0b', assuming commit. Could not find a tag or branch 'b0686a76f1ce3532088c4aee6e76b9abe61cc808', assuming commit. Could not find a tag or branch 'd89aae2a82f2b', assuming commit. [... more lines with the same content ....] Could not find a tag or branch 'a286e89c73e1b788e35ac5b08a54b71a9fa63cfd', assuming commit. Could not find a tag or branch '64a8b603f42669bb7fdca03d364d4e8d3d6ad67d', assuming commit. Could not find a tag or branch '172a90fd2738f8142c10478356b2d9ed3e55334a', assuming commit. pip install -q --exists-action w -r requirements/edx/local.txt You are using pip version 6.0.8, however version 7.1.0 is available. You should consider upgrading via the 'pip install --upgrade pip' command. pip install -q --exists-action w -r requirements/edx/base.txt You are using pip version 6.0.8, however version 7.1.0 is available. You should consider upgrading via the 'pip install --upgrade pip' command. meliae is potentially insecure and unverifiable. Requested meliae==0.4.0 (from -r requirements/edx/base.txt (line 53)), but installing version None Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-rNPjSe/dm.xmlsec.binding`<br> Captunetworking Task Output: --------------------- ---> pavelib.servers.devstack ---> pavelib.prereqs.install_prereqs ---> pavelib.prereqs.install_ruby_prereqs ---> pavelib.prereqs.install_node_prereqs ---> pavelib.prereqs.install_python_prereqs pip install -q --exists-action w -r requirements/edx/pre.txt pip install -q --exists-action w -r requirements/edx/github.txt pip install -q --exists-action w -r requirements/edx/local.txt pip install -q --exists-action w -r requirements/edx/base.txt Build failed running pavelib.servers.devstack: Subprocess return code:1 

Por cierto, ya he intentado actualizar pip, parece que todo está bien (instalado con éxito pip-7.1.0), pero siempre recibo ese post cuando pruebo el estudio pavstack devstack.

si los pasos anteriores no funcionan, intente instalar Cython, meliae == 0.4.0 y libxmlsec1 desde la instancia de Vagrant.

Resuelve este problema con algunos pasos:

 Requested meliae==0.4.0 (from -r requirements/edx/base.txt (line 53)),but installing version None 

Esta línea define que hay algún error en el file base.txt cuando el vagrant intenta instalar todas las dependencies de files base.txt.

Resuelve esto en pasos:

1) Abre el file base.txt y comenta meliae==0.4.0 line like ( #meliae==0.4.0 )

2) Ahora testing pip install -r base.txt file pip install -r base.txt si se ejecuta correctamente, entonces no hay problema o si algún otro package crea un problema, entonces sigue el paso 1 (comenta esto por ahora).

3) después de ejecutar base.txt 3.1) exit de edx-platform 3.2) En instancia vagabunda (viene después del command vagrant ssh ) instalar todos los packages comentados ( pip install meliae==0.4.0 en mi caso)

AHORA ejecute su sistema lms de nuevo 🙂