Utilizando Compositor privado VCS Git Repo

Estoy tratando de usar mi repository con el compositor. Obtenerlo como tipo de package, etc. funcionó bien, pero me gustaría usarlo como un VCS.

Entonces, agregué un compositor.json a mi repository mirando así:

{ "name": "gkm/storage", "authors": [ { "name": "David Schunke", "email": "my@email.me" } ], "require": { "php": ">=5.3.0" }, "autoload": { "psr-0": { "Gkm\\storage\\": "" } } } 

En el proyecto, donde deseo utilizar la biblioteca de este repository, agregué este compositor. Json:

 { "repositories": [ { "type": "vcs", "url": "git@gitlab.my.domain.com:gkm/storage.git" } ], "require": { "gkm/storage": "*" } } 

Ahora, cuando realizo una actualización del compositor, devuelve un error:

Problema 1: el package solicitado gkm / storage no se pudo encontrar en ninguna versión, puede haber un error tipográfico en el nombre del package.

Desafortunadamente, no encuentro información muy detallada sobre esto. Comparándolo con bibliotecas de terceros que hacen lo mismo, pero que acaban de publicarse a través de packagist.org en lugar de un server de repo personalizado, tiene el mismo aspecto.

Espero que alguien aquí vea lo que está mal.

¿Etiquetaste una versión? De lo contrario, Composer no puede resolver "*" a una versión, y no permitió la estabilidad del desarrollo para ese package instalado.