Usa la versión exacta de lib de NPM

Utilizamos las siguientes lib como dependencies en nuestro proyecto https://github.com/rlidwka/sinopia

En esta lib el package.json usan https://github.com/rlidwka/sinopia/blob/master/package.yaml express

 dependencies: express: '>=5.0.0-0 <6.0.0-0' 

que es muy problemático y no podemos usarlo ya que la versión 5 (5.0.0-alfa.1) no es oficial fuera
https://github.com/expressjs/express la versión lanzada de npm es 4.14 mi pregunta es la siguiente

  1. ¿Cuál es el sentido de declarar dependencies de esta manera que aún no se ha publicado?
  2. ¿Hay alguna forma de restringir la versión a 4.14 u otra versión 5 (no la versión alfa) sin hacer fork a este repository?

¿Cómo anulo las versiones anidadas de dependencia de NPM? sugiere usar un npm-shrinkwrap.json parcial para lograr lo que desea.

De acuerdo con Allow partial npm-shrinkwrap.json para forzar solo algunas dependencies , esto es compatible con npm @ 3.