"Un error interno producido durante la confirmación SVN: longitud 16416 fuera de range, debe estar entre 0 y 1384"

Tengo un problema al comprometer un montón de files .jar con eclipse. ¿Tal vez eclipse piensa que son files de text y no binarys?

Si ese es el problema, ¿cómo lo verifico? ¿Y cómo lo cambio?

Si no es así, ¿entonces qué es?

texto alternativo

Qué versión de:

  • eclipse
  • jdk
  • svn plugin

¿Estas usando?

podrías copyr la stack de llamadas que puedes ver en los loggings de eclipse (en la "vista de error" de eclipse)

Este hilo , por ejemplo, sugiere que el OP estaba usando el JDK incorrecto. Usar el último JDK (vea este eclipse.ini ) aquí podría ser una buena idea. (Lo mismo en este otro hilo ).
En ambos hilos, se muestra una stack de llamadas similar:

java.lang.IllegalArgumentException: length 16416 out of range; must be between 0 and 16384 at gnu.javax.net.ssl.provider.Record.setLength(libgcj.so.81) at gnu.javax.net.ssl.provider.OutputSecurityParameters.encrypt(libgcj.so.81) at gnu.javax.net.ssl.provider.SSLEngineImpl.wrap(libgcj.so.81) at javax.net.ssl.SSLEngine.wrap(libgcj.so.81) at gnu.javax.net.ssl.provider.SSLSocketImpl$SocketOutputStream.write(libgcj.so.81) at java.io.BuffenetworkingOutputStream.write(libgcj.so.81) at org.tmatesoft.svn.core.internal.util.SVNLogOutputStream.write(SVNLogOutputStream.java:65)