svn preguntando por la actualización de la copy de trabajo después de actualizar a MacOS Sierra

Así que actualicé a MacOS Sierra y ahora cada vez que trato de hacer algo en mi copy de trabajo obtengo el error de que

"es demasiado viejo (formatting 29) para funcionar con la versión de cliente '1.9.4 (r1740329)' (se espera el formatting 31). Primero debe actualizar la copy de trabajo."

Cuando ejecuto svn upgrade, como sugiere, dice "No se puede abrir el file /.svn/entries: no existe ese file o directory"

¡Cualquier sugerencia será muy apreciada!

Su problema es que la versión del cliente SVN se actualizó localmente; mientras que su copy de trabajo local (y el server) no cambió! Ahora el nuevo cliente no puede trabajar con la copy de trabajo existente.

Ahora tienes tres opciones:

  1. Puede intentar que su nuevo cliente SVN acepte la copy de trabajo existente
  2. Usted degrada su cliente SVN local a la versión anterior
  3. Arrojas tus repositorys existentes y comienzas con cajas nuevas

Para la opción 1, puede mirar aquí o allá .

Para la opción 2, esto podría ayudar.

Opción 3; Supongo que es una línea sin pan comido que quizás le cueste time de descarga, pero debe venir con la menor cantidad de "usted gastando su time" depurando esto (a less que tenga una tonelada de cambios no comprometidos sentados en sus repositorys actuales) . Pero, por supuesto, primero debería intentar crear un nuevo pago con el nuevo cliente, antes de tirar el viejo directory.

  1. Terminal abierto
  2. Ve a la carpeta de error. ex: cd svn / project / game
  3. command escribir solo "svn upgrade"

Resolví mi problema haciendo la 'actualización svn' en el 'cd' de la carpeta raíz del proyecto