Sus proyectos contienen errores, por favor, corríjalos antes de ejecutar: Eclipse

Estoy construyendo una aplicación de Android en la que he importado una de las bibliotecas de maven desde este enlace https://github.com/devnied/EMV-NFC-Paycard-Enrollment.My nombre del proyecto es Nfcs y no tengo errores en el proyecto y He agregado todas las dependencies en mi proyecto con éxito pero cuando ejecuto la window de error del proyecto se abre diciendo "Tus proyectos contienen errores, por favor, corrígelos antes de ejecutarlos". Por favor, ayúdame a descubrir el error … enter image description here

enter image description here

pom.xml del proyecto de la biblioteca.

<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd"> <modelVersion>4.0.0</modelVersion> <artifactId>library</artifactId> <packaging>jar</packaging> <name>EMV paycard library</name> <parent> <groupId>com.github.devnied.emvnfccard</groupId> <artifactId>parent</artifactId> <version>1.1.1-SNAPSHOT</version> </parent> <dependencies> <dependency> <groupId>com.github.devnied</groupId> <artifactId>bit-lib4j</artifactId> </dependency> <dependency> <groupId>org.apache.commons</groupId> <artifactId>commons-lang3</artifactId> </dependency> <dependency> <groupId>org.apache.commons</groupId> <artifactId>commons-collections4</artifactId> </dependency> <dependency> <groupId>commons-io</groupId> <artifactId>commons-io</artifactId> </dependency> <!-- Unit test --> <dependency> <groupId>junit</groupId> <artifactId>junit</artifactId> <version>4.11</version> <scope>test</scope> </dependency> <dependency> <groupId>org.easytesting</groupId> <artifactId>fest-assert</artifactId> <version>1.4</version> <scope>test</scope> </dependency> <dependency> <groupId>org.powermock</groupId> <artifactId>powermock-module-junit4</artifactId> <scope>test</scope> </dependency> <dependency> <groupId>org.powermock</groupId> <artifactId>powermock-api-easymock</artifactId> <scope>test</scope> </dependency> <dependency> <groupId>cglib</groupId> <artifactId>cglib</artifactId> <scope>test</scope> </dependency> </dependencies> <build> <plugins> <plugin> <groupId>org.eluder.coveralls</groupId> <artifactId>coveralls-maven-plugin</artifactId> </plugin> <plugin> <groupId>org.codehaus.mojo</groupId> <artifactId>cobertura-maven-plugin</artifactId> </plugin> </plugins> </build> </project> 

Tu post de error dice:

 ... Run Maven->Update Project or Use Quick Fix. 

Como ve que el error está en su Proyecto Maven, ¡debe seguir la sugerencia que Eclipse le brinda! Y haga clic con el button derecho en su proyecto Maven> Maven> Actualizar proyecto.

Por lo general, las sugerencias de Eclipse son bastante útiles.

Lea esta publicación para comprender para qué se usa esta function. Debe tener en count que Maven no es el administrador de compilation "nativo" en Eclipse y, por lo tanto, necesita una pequeña adaptación y operaciones adicionales para que funcione correctamente.