Servicio SVN y post de error PySVN: formatting FS esperado entre '1' y '3'; formatting encontrado '4'

Para fines de investigación, copié un repository SVN a mi máquina con Windows usando svnsync para poder reproducirlo en mi máquina sin cargar el server real.

He estado usando PySVN en scripts para controlar el número de revisión en el que quiero que esté el repository y lo he estado usando bien hasta ahora. Ahora obtuve un repo de un proyecto diferente y svnsync lo tuvo bien. Cuando bash ejecutar el script en Ubuntu obtengo: el Expected FS format between '1' and '3'; found format '4' Expected FS format between '1' and '3'; found format '4'

De lo que pude aprender de otras preguntas en StackOverFlow y en otros lugares, parece que mi ubuntu pysvn está desactualizado para una versión de 1.6 subversión y solo funcionaría para 1.5. ¿Entendí esto correctamente?

Porque en la página de descarga de pysvn dice que "Esta versión de pysvn ha sido probada contra Subversion 1.5.6 y Subversion 1.6.5 "

Cuando hago sudo apt-get install python-svn me dice que python-svn ya es la versión más nueva. Así que supongo que PySVN no es compatible con los repositorys Subversion 1.6.

Pero si bash ejecutar exactamente el mismo script en un cuadro de Windows, con solo el module pysvn (sin installation de svn) y los files de repos locales, ¡se ejecuta correctamente y puedo verificar los files!

Entonces estoy confundido ¿Por qué PySVN se ejecuta con los repositorys de formatting 4 de FS en Windows y no en Ubuntu?

¿Qué versión de Ubuntu tienes? 9.04? No tiene subversión 1.6 afair.

Qué versiones hacen

 dpkg -l subversion dpkg -l python-svn 

¿informe?