requisitos rvm instalar error git

Estoy tratando de instalar rvm con el último ruby ​​en un server centos 5, rvm ya está instalado sin ruby, arroja un error al intentar instalar ruby, algo relacionado con git.

 $ uname -a Linux 2.6.18-308.24.1.el5PAE #1 SMP Tue Dec 4 18:28:32 EST 2012 i686 i686 i386 GNU/Linux $ rvm install ruby-2.2-head Checking requirements for centos. Installing requirements for centos. Installing requinetworking packages: git, autoconf....... Error running 'requirements_centos_libs_install git autoconf', showing last 15 lines of /home/ruby/.rvm/log/1442954643_ruby-2.2-head/package_install_git_autoconf.log --> Missing Dependency: perl(Error) is needed by package git-1.8.2.1-1.el5.i386 (epel) git-1.8.2.1-1.el5.i386 from epel has depsolving problems --> Missing Dependency: perl(Term::ReadKey) is needed by package git-1.8.2.1-1.el5.i386 (epel) git-1.8.2.1-1.el5.i386 from epel has depsolving problems --> Missing Dependency: perl(Git) is needed by package git-1.8.2.1-1.el5.i386 (epel) Error: Missing Dependency: perl-Git = 1.8.2.1-1.el5 is needed by package git-1.8.2.1-1.el5.i386 (epel) Error: Missing Dependency: perl(Term::ReadKey) is needed by package git-1.8.2.1-1.el5.i386 (epel) Error: Missing Dependency: perl(Git) is needed by package git-1.8.2.1-1.el5.i386 (epel) Error: Missing Dependency: perl(Error) is needed by package git-1.8.2.1-1.el5.i386 (epel) You could try using --skip-broken to work around the problem You could try running: package-cleanup --problems package-cleanup --dupes rpm -Va --nofiles --nodigest ++ return 1 ++ return 1 Requirements installation failed with status: 1. $ git --version git version 1.6.4.4 

Este server utiliza cpanel.

Intenté instalar directamente con yum, el mismo error, intenté también eliminar git

  # yum remove git Failed to set locale, defaulting to C Loaded plugins: downloadonly, fastestmirror Setting up Remove Process No Match for argument: git 

Supongo que Cpanel tiene instalado git, pero es una versión obsoleta, ¿podría ser esto?

Pruebe las respuestas proporcionadas aquí – https://github.com/rvm/rvm/issues/2696 – específicamente arreglando lo que vaya mal cuando intenta hacer esto …

yum install -y libyaml-devel autoconf gcc-c++ readline-devel zlib-devel openssl-devel