requisitos de pip.txt github repo django aplicación

He bifurcado un informe sobre Github para hacer mis propios cambios. He enviado una request de extracción al repository original, pero mientras espero me gustaría agregar mi repository a mis requerimientos de pip.txt.

He agregado la línea así:

[...] -e git+https://github.com/eldamir/django-datatable-view.git#egg=datatableview 

Luego ejecuto pip install -r requirements.txt . El repository se descarga. Intento importar el module para asegurarme de que funciona:

 python -c "import datatableview" 

Sin errores. Todo está bien. Sin embargo, como esta es una aplicación django, necesito agregarla a mi INSTALLED_APPS . Al hacerlo, no se produce ningún error, pero el cargador de templates no parece encontrar las templates de la aplicación. Esto funcionó bien cuando pip install django-datatable-view . Supongo que mi file setup.py bifurcado funciona tan bien como el original. Entonces, ¿qué es diferente aquí?

Actualización1

El file MANIFEST.in contiene

 include README.md include requirements.txt recursive-include datatableview/static * recursive-include datatableview/templates * 

No sé mucho sobre el propósito de este file, pero supongo que este es el que recostack los files y los coloca en su lugar. La carpeta de templates se incluye recursivamente

Revise su carpeta virtualenv src o similar donde está instalado el package para confirmar que realmente instala todos los files, particularmente el file faltante.

Lo más probable es que se trata de un problema de empaquetamiento causado por la falta del file MANIFEST.in en el package y necesita una corrección de errores.

Agregue nombres de file faltantes, loggings de seguimiento relevantes, etc. a la pregunta si no resuelve el problema.