Repo de Git de Eclipse en W7 importado a Eclipse en Mac, ¿por qué error de "nivel de cumplimiento del comstackdor"?

Tengo una pequeña aplicación de Android desarrollada en Eclipse en Windows y versionada en Github. Ahora que lo cloné y lo importé de Github a Eclipse en una Macbook, aparece el error de que "Android requiere el cumplimiento del comstackdor del nivel 5.0 o 6.0. En su lugar, encontró '1.4'. Utilice Android Tools> Fix Project Properties."

Miré por aquí, y esto parece tener algo que ver con la versión java, pero el sdk java instalado en el Macbook es SE 6, lo mismo que en el equipo con Windows. También las versiones sdk de Android son las mismas (la última). Entonces no tengo idea de qué está pasando … ¿Alguna idea, sugerencia, alguien?

Además ,,, si hago estas correcciones, sean lo que sean, ¿tendré un problema después de tirar a la máquina de Windows?

Aunque tiene JDK 6, necesita establecer explícitamente nivel de cumplimiento Ventana – Preferences – Java-JRE – nivel de compilation, cambie a 1.6.

Es la configuration del nivel de eclipse, por lo que existe la posibilidad de que también ocurra en la máquina de Windows.