Referencias perdidas en la solución Visual Studio 2017

He estado trabajando en un proyecto con un compañero de trabajo y estamos usando Visual Studio 2017 como IDE y también Git para enviar las versiones al repository de VS. Tuvimos algunos problemas y decidimos comenzar un nuevo proyecto en Visual Studio con el contenido que ya teníamos.

Lo extraño es que cuando cloné el repository en mi computadora y lo sincronicé, algunas de las references se perdieron. Aparece un triángulo amarillo al lado de los íconos de references perdidas en el Explorador de soluciones, y no tiene una ruta establecida como las que funcionan. Además, dentro de Source> Repos, la carpeta del proyecto tiene todos los files, incluidos los que faltan. Traté de eliminar el proyecto y clonarlo de nuevo, intenté download solo el file .zip e iniciar el proyecto fuera de línea, y también ejecutar VS 2017 como administrador (parece que esto resolvió problemas similares para otros antes) y nada funcionó. Mi compañero de trabajo (quien empujó el proyecto al repository en primer lugar) puede comstackr normalmente y no enfrenta este problema de reference.

¿Alguien ha experimentado alguna vez este problema?

Una vez lo experimenté cuando estaba teniendo abierto un proyecto de Visual Studio 2015 y luego sacaba nuevos commit de git. El nuevo proyecto que estaba sacando fue configurado para Visual Studio 2017 sin embargo.

Así que mi VS 2015 estaba abierto y exhibiendo el proyecto ahora VS 2017. Creo que solo contenía un package Nuget, sin embargo, esto no se descargó correctamente y, en cambio, el package se mostró como un file perdido.

Tal vez esto te está pasando a ti también?