Python: tratando de usar bibliotecas de terceros en git hooks

Estoy tratando de utilizar el module javalang en mi gancho precompromiso, pero aparece un error en la línea donde está intentando instalar javalang.

No sé por qué sucede esto porque he instalado javalang utilizando pip a través de mi terminal.

He adjuntado una captura de pantalla del error, ¿alguien puede ayudar a identificar cómo puedo solucionar este problema?

EDITAR: Aquí están las primeras líneas de mi gancho

#!/usr/bin/env python from __future__ import print_function import sys import subprocess import os import json import javalang import re from xml.etree import ElementTree as ET 

enter image description here

EDIT: Creo que he encontrado una gran pista. Cuando abro mi terminal y ejecuto mi versión de Python 2.7, puedo importar javalang. Sin embargo, si ejecuto mi versión de python3, no puedo importar javalang. Esto significa que sourcetree debe estar ejecutando python3. Previamente instalé javalang vía pip. ¿Esto significa que no se instaló en mi Python 3? ¿Solo 2?