Problemas de clonación de Github

Recibo este extraño post de error cuando bash clonar o extraer de git. Lo extraño es que yo y un colega no tuvimos problemas anteriormente con esto. Luego obtuvimos otros dos miembros del equipo para clonar el repository y ahora, de repente, yo y el colega anterior seguimos recibiendo estos errores. Los dos nuevos chicos no tienen problemas para jalar / empujar y clonar. De repente, los dos miembros originales del equipo no pueden hacer nada.

No me puedo imaginar lo que los dos nuevos miembros pudieron haber modificado o cambiado, solo estamos haciendo cosas sencillas en este momento. ¿Es posible que sea un problema con GitHub y las counts de miembros anteriores del equipo?

Cloning into test... Enter passphrase for key '/c/Users/Rob/.ssh/id_rsa': remote: Counting objects: 8685, done. remote: Compressing objects: 100% (3737/3737), done. remote: Total 8685 (delta 5005), reused 8490 (delta 4810) Receiving objects: 100% (8685/8685), 239.92 MiB | 158 KiB/s, done. Resolving deltas: 100% (5005/5005), done. error: refs/remotes/origin/master does not point to a valid object! error: Trying to write ref refs/heads/master with nonexistant object 3cad1d0fb95b397ae8ed4826e29073362e135e2f fatal: Cannot update the ref 'HEAD'. Unlink of file 'test/.git/objects/pack/pack-9bca633d2527e271701b07f92128b15a6396277a.idx' failed. Should I try again? (y/n) 

ACTUALIZACIÓN: Acabo de intentar configurar una nueva count en github e intenté clonar de nuevo, pero con los mismos problemas, lo que supongo que se networkinguce a algún tipo de configuration global que pueda tener en github.

Tenía este problema exacto y no pude encontrar una buena respuesta para él originalmente. Después de muchas vueltas en el escritorio, fue bastante simple para mí: tenía un cliente de git más viejo.

  • mi server que estaba usando git to do deploys, estaba ejecutando git 1.7.1 (distribución pnetworkingeterminada para Centos6 al momento de escribir)
  • git ahora es hasta 1.7.12
  • claramente algunos de mis otros clientes se habían comprometido a usar funciones que no eran compatibles con versiones anteriores.

Hice una actualización del cliente de git en el server. Los problemas se fueron. Espero que ayude a alguien con el mismo problema.

(Para el logging, Instalar git desde la fuente en Centos6 fue v.helpful)

Esto terminó siendo un extraño error con el cliente de git, volví a instalar y todo funcionó bien después de eso.