Problema del subspec de Cocoapods: ninguna de sus fonts de especificaciones contiene una especificación que satisfaga la dependencia

Modifiqué un repository en Github para integrar una versión rápida de mi biblioteca.

https://github.com/iDevelopper/PBRevealViewController

Sin embargo, cuando en un nuevo proyecto bash instalar pod, obtengo el error:

[!] No se pueden cumplir los siguientes requisitos:

  • PBRevealViewController/Swift (= 1.2.3) requerido por Podfile

Ninguna de sus fonts de especificaciones contiene una especificación que satisfaga la dependencia: PBRevealViewController/Swift (= 1.2.3) .

Usted tiene: repos repos sin actualizar que puede actualizar con actualización de pod repo update o con pod install --repo-update . * escribió mal el nombre o la versión. * no se agregó el repository de origen que aloja el Podspec a su file Podfile.

Nota: a partir de CocoaPods 1.0, la pod repo update no ocurre en la pod install por defecto.

¡Algunas ayudas son bienvenidas!

Por favor, vea el problema Cocoapods:

https://github.com/CocoaPods/CocoaPods/issues/6970#event-1213956994

No estoy familiarizado con esto, pero también enfrenté el mismo problema. Seguí los pocos pasos.

borre su file de pod y regenere su file de pod nuevamente use los siguientes pasos,

  • pod repo eliminar maestro

  • configuration de pod

  • pod instalar