Problema de actualización de SVN en Eclipse

He estado usando SVN con Eclipse durante años sin problemas. Pero, de repente, un proyecto no funciona correctamente, aunque otros están bien.

Cuando bash actualizar, obtengo esto:

texto alternativo

En el logging de Eclipse veo: U

formatting de copy de trabajo no compatible svn: este cliente es demasiado viejo para trabajar con la copy de trabajo 'C: \ Work \ xxxxxxxxxxxx \ client'; por favor obtenga un cliente de Subversion más nuevo

¿Algunas ideas? No veo cómo actualizar el complemento SVN aunque sea demasiado antiguo …

En algún momento, alguien ejecutó un comentario SVN en su sandbox usando un cliente que usa un script más reciente que su plugin (probablemente un cliente de Subversion 1.5 donde previamente había estado usando 1.4).

Si no actualiza su cliente / complemento, puede volver a consultar su sandbox con su cliente / complemento preferido, o usar el script change-svn-wc-format.py, como se detalla en las notas de la versión de Subversion 1.5, en Working Copy y cambios de formatting de repository .

Los clientes de Subversion actualizan automáticamente su copy de trabajo cuando la tocan. Como dijo Blair, algo ha tocado tu copy de trabajo probablemente con un cliente 1.5.

Debe mantener todos sus clientes de Subversion diferentes: CollabNet (línea de command), TortoiseSVN, Subclipse, Subversivo, etc., todos en la misma versión menor (1.4 contra 1.5), o continuará teniendo este problema.

Blair tiene una buena estrategia para solucionarlo, pero lo más fácil sería volver a pagar la copy de trabajo.

Puede intentar configurar el complemento SVN (¿subclipse?) Para usar svnkit en lugar del cliente nativo.

Si la subversión no está incluida en su complemento SVN, entonces necesita actualizar su cliente svn. ¿Has comprobado si el server con el que te estás conectando no se ha actualizado?