Problema con SourceTree al clonar un repository de GitHub

Sé que una pregunta similar ya está publicada aquí, sin embargo, creo que mi situación es un poco diferente. Esto es lo que tengo.

Descargué e instalé la última versión oficial del software SourceTree. Además, tengo la count de GitHub con permissions para clonar y enviar el repository. Para administrar una copy local, necesito clonar la versión en línea. Estos son los pasos que tomo:

  1. Inicie el Source Tree y vaya a Archivo -> Clonar / Nuevo …
  2. En la window abierta, pego la URL de clonación de HTTPS . Lo copié del browser después de iniciar session en mi count de GitHub, por lo que el enlace es correcto.
  3. El paso del nido es especificar una carpeta local donde se copyrá el repository. Pero cuando hago clic para ingresar a la Ruta de destino , la window muestra un error que dice: " Esta no es una ruta / URL válida " y un button Detalles al lado del error.

Pero el problema es que los Detalles están vacíos. El Source Tree no me dice el motivo del error o cualquier otra cosa. Intenté volver a instalar SourceTree, pero el error aún existe. Le pedí a la Administración del repository de GitHub cualquier otro permiso, pero mi count los tiene todos. Puedo enviar cambios al repository en línea usando la console del terminal, pero me gustaría utilizar la interfaz de usuario (que proporciona SourceTree) para administrar y comparar los cambios en el código.

Uno piensa que no lo intenté es clonar el repository usando otra count de GtHub. Pero no quiero hacer eso porque necesito realizar cambios en el repository en mi nombre.

¿Alguien sabe cómo se puede corregir o solucionar este error?

El post de error exacto es (como se ilustra aquí ):

This is not a valid source path / URL 

mensaje de error en sourcetree

Causa posible:

  • configuration de proxy (como en este hilo )
  • pasos de configuration, con Git desactivado (como aquí )

    Cuando SourceTree comenzó por primera vez, omití la configuration de Git & Mercurial en el asistente. Luego cambié el asistente y elegí download e instalar los packages integrados.
    Pero parece que instalarlos realmente no los habilitaba – en el dialog Tools -> Options ambos estaban deshabilitados.
    Habilitar Mercurial (o Git en su caso) permitió que el dialog de clonación identificara correctamente el repository.

  • problemas de cnetworkingenciales (como aquí , de mi viejo contestador )

También puedo agregar que resolví este problema instalando Git a través de SourceTree desde [SourceTree]> Tools> Options> Git.

Como había estado usando mercurial exclusivamente en ese sistema hasta entonces, nunca había sido instalado, y estaba presentando el error descrito anteriormente al tratar de clonar.

¡Espero que esto ayude a alguien con el mismo problema! Si no, ¡buena suerte!

Tuve que desinstalar y reinstalar SourceTree antes de que funcionara. Creo que mi antivirus (Comodo) estaba bloqueando / sandboxing algunas cosas en la installation inicial, así que lo deshabilité para la reinstallation.

Estaba enfrentando el mismo problema con Windows 10 y el tree fuente. Después de un poco de investigación, la siguiente solución funcionó para mí. Necesitaba download o habilitar el soporte git en el tree de fonts.

Pasos 1) Vaya a Herramientas -> Opciones -> Git -> Habilite la compatibilidad git

Eso es lo que resolvió mi problema. Feliz encoding 🙂

Estaba enfrentando el mismo problema con Windows 10 y el tree fuente. Después de un poco de investigación, la siguiente solución funcionó para mí. Necesitaba download o habilitar el soporte git en el tree de fonts.

Pasos 1) Vaya a Herramientas -> Opciones -> Git -> Habilite la compatibilidad git

Eso es lo que resolvió mi problema. Feliz encoding 🙂

También tuve el mismo problema. This is not a valid source path / URL y se resolvió actualizando el Git embedded del Árbol de fonts.

Este problema también se manifestó cuando no pude empujar o tirar de repositorys previamente clonados y activos en el tree de fonts. Me quejé sobre el nombre de usuario y la contraseña de authentication, pero claramente ese no era el caso.

Pasos a resolver: tree de código abierto, Herramientas -> Opciones -> Hacer clic en la pestaña Git -> Actualizar Embedded Git.