Página de descargas de Chrome en lugar de mostrar

Tengo un problema extraño en github y bitbucket. Chrome ocasionalmente descarga una página en lugar de mostrarla. Si cancelo la descarga y vuelvo a hacer clic, funciona. Tengo la corazonada de que puede ser porque el tipo de contenido es application / x-gzip … ¿Alguien ha hecho experiencias similares o una solución? ¡Gracias por adelantado!

[EDIT]: @genkev: el tipo de respuesta de mimet es application / x-gzip. No tengo ni idea, por qué se envía de esta manera o por qué no se muestra regularmente pero solicita al browser que descargue el file. No diré que es un problema de browser ni un problema de server, pero es un (mi) problema de todos modos.

{ "startedDateTime": "2012-11-29T08:27:08.503Z", "time": 3, "request": { "method": "GET", "url": "https://github.com/LearnBoost/socket.io/wiki", "httpVersion": "HTTP/1.1", "headers": [ { "name": "Accept-Encoding", "value": "gzip,deflate,sdch" }, { "name": "Accept-Language", "value": "de-DE,de;q=0.8,en-US;q=0.6,en;q=0.4" }, { "name": "Cookie", "value": "uninteresting cookie" }, { "name": "Connection", "value": "keep-alive" }, { "name": "Accept-Charset", "value": "ISO-8859-1,utf-8;q=0.7,*;q=0.3" }, { "name": "Host", "value": "github.com" }, { "name": "User-Agent", "value": "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11" }, { "name": "Accept", "value": "text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8" }, { "name": "Referer", "value": "https://github.com/LearnBoost/socket.io/issues" } ], "queryString": [], "cookies": [ "some cookies" ], "headersSize": 1678, "bodySize": 0 }, "response": { "status": 200, "statusText": "OK", "httpVersion": "HTTP/0.9", "headers": [], "cookies": [], "content": { "size": 0, "mimeType": "application/x-gzip", "compression": 0 }, "networkingirectURL": "", "headersSize": 19, "bodySize": 0 }, "cache": {}, "timings": { "blocked": 0, "dns": -1, "connect": -1, "send": 0, "wait": 0, "receive": 1, "ssl": -1 }, "pageref": "page_2" } 

Definitivamente un problema de extensión. Para mí fue "Hover Zoom 4.11.3" que causó esto.

¡He resuelto el problema! Fue causado por la extensión Webug 1.2.3 FirePHP para Google Chrome. No sé si las versiones futuras de este complemento también tienen este error.