No se puede npm instalar confirmación específica de la biblioteca angular de github

Estoy usando Angular 2.0.0-beta.15 y no puedo actualizarlo, así que tuve que encontrar una confirmación específica de la biblioteca github ( ng2-dnd ).

Así que encontré este compromiso que soporta 2.0.0-beta.17 que debería funcionar para mí:

"ng2-dnd": "git://github.com/akserg/ng2-dnd.git#87a6cc0d395ebc2d14734769a3190836c8af6e1a" 

pero cuando voy a npm install consigo un error:

 npm ERR! addLocal Could not install /var/folders/n6/3vqr57k94_z7ynl99yvvtv1r0000gn/T/npm-9640-99198f21/git-cache-fef0b17f/87a6cc0d395ebc2d14734769a3190836c8af6e1a npm ERR! Darwin 15.3.0 npm ERR! argv "/usr/local/Cellar/node/5.6.0/bin/node" "/usr/local/bin/npm" "install" npm ERR! node v5.6.0 npm ERR! npm v3.6.0 npm ERR! No version provided in package.json npm ERR! npm ERR! If you need help, you may report this error at: npm ERR! <https://github.com/npm/npm/issues> 

¿Alguien sabe cómo puedo superar esto?

¡Gracias!

Puede usar ng2-dnd versión 1.5.0

Actualice su package.json con:

 "ng2-dnd" : "1.5.0"