No se puede importar la biblioteca de volley en eclipse

Acabo de get la biblioteca de volley desde el siguiente enlace .. git clone- https://android.googlesource.com/platform/frameworks/volley en eclipse Estoy siguiendo los pasos import> git> project from git> …. etc

y la biblioteca se descargó en C: \ Users \ active \ git \ voley

cuando solo quiero importar la carpeta de volley al eclipse (C: \ Users \ active \ git \ volley) muestra " Seleccionar al less un proyecto " en PROYECTO DE IMPORTACIÓN. Y su es solo un proyecto aunque he seleccionado que aún muestra el mismo error en la parte superior. En serio necesita ayuda … gracias de antemano

Necesita build el jar y luego agregarlo a su carpeta libs en su proyecto.

Cómo build el jar

$ git clone https://android.googlesource.com/platform/frameworks/volley $ cd volley $ android update project -p . $ ant jar 

fuente

Aquí hay un video de YouTube si eso ayuda: https://www.youtube.com/watch?v=5bwn7DYt2AI

También puede download una compilation no oficial en maven central .

Editar:

Parece que la volea ya no se puede build con ant (corrígeme si estoy equivocado). Todo lo que hice fue crear un nuevo proyecto de Android, marcarlo como un proyecto de biblioteca, crear el package com.android.volley, copyr el origen al proyecto y comstackrlo.

Compruebe si el nombre del proyecto ya existe en su espacio de trabajo.

  1. Haga clic con el button derecho en cualquier proyecto y click properties .
  2. Mire el directory del WorkSpace actual debajo de la location .
  3. Elimine cualquier copy existente de Volley o proyecto con el mismo nombre.
  4. Vuelva a importar Volley.