No se puede ejecutar un repository clonado

¿Cómo descargo mi código anterior de github? Cometí un error en mi aplicación, y cuando bash download el file zip anterior de github y ejecutarlo, aparece un error.

Creo que lo estoy haciendo bien, ¿no solo necesito clonar el repository? Cuando lo hago, aparece este error cuando bash ejecutar el server:

An error occurnetworking while installing pg (0.17.0), and Bundler cannot continue. Make sure that `gem install pg -v '0.17.0'` succeeds before bundling. 

y cuando ejecuto la installation bundel sigo recibiendo el error.

También recibo este error:

 bundle install doesn't work and I still get the error along with this one:Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension 

Si ha instalado Mavericks, esa es la fuente de su problema. Tuve que instalar otra joya con dependencies nativas que necesitaban comstackrse después de instalar Mavericks, y algunos cambios en cuanto al comstackdor que usa Mavericks para comstackr dependencies de gems crean problemas. En su caso, le sugiero que elija una de las soluciones en esta respuesta para resolver sus problemas de installation de PG.

Me parece que no tienes que instalar Postgres. Instálalo e intenta bundle install nuevamente. Cómo instalar Postgres en Ubuntu (por supuesto, puedes tener otro sistema :)) – https://help.ubuntu.com/community/PostgreSQL