No se pudo encontrar la versión del compositor para su estabilidad mínima (estable). Verifique la ortografía del package o su estabilidad mínima

Revisé todas las preguntas y soluciones en el desbordamiento de stack. Pero no pude resolver este problema. Mensaje de error :

* [InvalidArgumentException] Could not find package selimppc/hello-world at any version for your minimum-stability (stable). Check the package spelling or your minimum-stability *

Aquí está mi file composer.json ::

 { "name": "Hello worlds Apps", "description": "New Apps from SelimReza.com", "type": "library", "license": "MIT", "authors": [{ "name": "Selim Reza", "email": "me@selimreza.com" }], "require": { "php": ">=5.6", "selimppc/hello-world": "@dev" }, "minimum-stability": "dev", "prefer-stable": true, "autoload": { "psr-4": { "HelloWorld\\": "src\\HelloWorld\\" } } } 

URL de Github: https://github.com/selimppc/hello-world

No puedo imaginar la solución para este error. También, hágamelo saber la forma de resolver y las causas de este.

¡Gracias por adelantado!

dev-master no es una estabilidad válida:

Las opciones disponibles (en order de estabilidad) son dev, alpha, beta, RC y estable.

Ver: https://getcomposer.org/doc/04-schema.md#minimum-stability

Además, el package no se puede referir a sí mismo, tendrá que cambiar el nombre en su package. Json.

Si cambio el nombre y la estabilidad mínima a dev. Funciona.

No necesitarás los repositorys, también se refieren a sí mismos

 { "name": "some/new-name", "description": "New Apps from SelimReza.com", "type": "library", "license": "MIT", "authors": [{ "name": "Selim Reza", "email": "me@selimreza.com" }], "require": { "php": ">=5.6", "selimppc/hello-world": "dev-master" }, "minimum-stability": "dev", "prefer-stable": true, "autoload": { "psr-4": { "HelloWorld\\": "src\\HelloWorld\\" } } }