No se pudo abrir el sistema de files SVN solicitado en Windows7

mientras configuraba httpd de apache con subversion en Windows 7, obteniendo el error debajo .. ya había instalado con diferentes types de versiones de SVN y apache también todavía estoy enfrentando este problema … podría por favor que alguien me ayude con este problema …

svn, version 1.9.1 (r1698128) `compiled Sep 1 2015, 19:50:43 on x86-microsoft-windows` httpd-2.2.22-win32-x86-openssl-0.9.8t, Server version: Apache/2.2.22 (Win32) Server built: Jan 28 2012 11:16:39 

y previamente había instalado svn para 1.8.18 y httpd-2.2.25-win32-x86-openssl-0.9.8y

copié estos files debajo a apache / conf / httpd

 LoadModule dav_module modules/mod_dav.so LoadModule dav_fs_module modules/mod_dav_fs.so LoadModule dav_svn_module modules/mod_dav_svn.so LoadModule authz_svn_module modules/mod_authz_svn.so 

Obteniendo el siguiente error:

  This XML file does not appear to have any style information associated with it. The document tree is shown below. <D:error xmlns:D="DAV:" xmlns:m="http://apache.org/dav/xmlns" xmlns:C="svn:"> <C:error/> <m:human-readable errcode="160043">Could not open the requested SVN filesystem</m:human-readable> </D:error> 

Al principio, muestre su file httpd.conf completo y vea qué se ha registrado en el logging de Apache. Supongo que comprenderá la causa raíz mirando el logging.

A continuación, si tiene problemas para configurar el server SVN + Apache en Windows usted mismo, busque en la web soluciones todo en uno preenvasados. Por ejemplo, google "svn server windows". De lo contrario, consulte la página oficial de packages binarys .

Actualizar:

La parte más interesante del error registrado es:

 E160043: Expected FS format between '1' and '6'; found format '7' 

El error significa que tiene instalado Subversion 1.8 como su server. Sin embargo, el repository se creó utilizando las herramientas de Subversion 1.9 y tiene un formatting más nuevo. Debe asegurarse de que su server tenga la versión más reciente 1.9 o cree el repository con las herramientas 1.8. Existe otra opción que puede ayudarlo: crear el repository usando svnadmin create REPOSITORY --compatible-version 1.8 command.

El hecho de que cuando ejecuta svn --version ve la version 1.9.1 (r1698128) solo significa que su cliente de command-line tiene la versión 1.9.1. Esto es irrelevante para el lado del server.