No se encuentra la biblioteca de errores para -lCocoaAsyncSocket XCode 7.3 después de pulsar y clonar Git

Hemos usado pod para instalar la Biblioteca. En una computadora funciona bien. Pero cuando lo insertamos en Git y lo clonamos, me está dando este error:

ld: biblioteca no encontrada para -lCocoaAsyncSocket clang: error: el command del linker falló con el código de salida 1 (use -v para ver la invocación)

Incluso copymos el proyecto usando USB. Probamos "pod install". Pero eso tampoco funciona. Ambos estamos usando XCode 7.3

Ok, la mejor manera de limpiar ciertos problemas relacionados con los pods es limpiar todo y ejecutar nuevamente.

Tengo este procedimiento estándar que funciona cada vez que hay un error de vinculación con cocoaPods.

1.Mantenga una copy de security! (¡Esto puede romperse por completo!)

2.Desintegre un pod. Use esta biblioteca -> https://github.com/CocoaPods/cocoapods-deintegrate para llamar al command de desintegración del pod para limpiar todo con las cápsulas de cocoa.

3. Limpie la configuration del proyecto, eliminando todo lo editado. (Si lo hizo para que funcione algún marco, guárdelo) Elimine las routes de búsqueda, las routes del encabezado del marco, otros indicadores del linker Quite las configuraciones, Quite banderas, Quite PCH si hay Alguna que sea negrita en la configuration de compilation, lo que no se haya hecho explícitamente por usted para algún propósito, elimínelo para restablecer el valor pnetworkingeterminado.

4. Borre el espacio de trabajo y cualquier file pod del directory.

4. Extraiga su file pod principal de la copy de security.

5. Eliminar datos de derivedFolder, window -> proyectos -> eliminar datos derivados

6.Haga una carpeta limpia (producto -> limpio), e incluso limpie la compilation (opción de espera, haga el producto -> carpeta de compilation limpia)

7. Haz una installation de pod

8. Construir y correr.

¡Todo debería ser restaurado a estados felices!

Intereting Posts