No funciona la biblioteca de GitHub en Android Studio

No trabaje esta biblioteca desde GitHub en Android Studio My build.gradle (: project):

apply plugin: 'com.android.application' android { compileSdkVersion 23 buildToolsVersion "23.0.1" defaultConfig { applicationId "com.example.mymaterialdialogs" minSdkVersion 15 targetSdkVersion 23 versionCode 1 versionName "1.0" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) testCompile 'junit:junit:4.12' compile 'com.android.support:appcompat-v7:23.0.1' compile('com.afollestad.material-dialogs:core:0.8.4.2@aar') { transitive = true } } 

Y mi build.gradle (: aplicación):

 buildscript { repositories { maven { url "https://jitpack.io" } } dependencies { classpath 'com.android.tools.build:gradle:1.3.0' } } allprojects { repositories { jcenter() } } task clean(type: Delete) { delete rootProject.buildDir } 

Muestra este error:

Error: (26, 13) Error al resolver: com.afollestad.material-dialogs: core: 0.8.4.2 Mostrar en file (openFile: … / app / build.gradle)
Mostrar en el dialog Estructura del proyecto (open.dependency.in.project.structure)

Haga los siguientes pasos:

1.En su build.gradle (: project) Agregue lo siguiente antes de las dependencies

 repositories { maven { url "https://jitpack.io" } 

}

 dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) testCompile 'junit:junit:4.12' compile 'com.android.support:appcompat-v7:23.0.1' compile('com.afollestad.material-dialogs:core:0.8.4.2@aar') { transitive = true } } 

2.En tu build.gradle (: aplicación): replace

  maven { url "https://jitpack.io" } with jcenter() 

Proyecto 3.Sync

Espero que esto ayude.