Manejo de dependencies desactualizadas en Gerrit

Tengo un cambio de revisión en el estado Merge Pending. El cambio depende de otro cambio que está desactualizado. Dependency tiene una versión más nueva que ya está fusionada.

Traté de usar el button rebase para rebase el cambio pendiente que no fue exitoso, el conflicto causado por el rebase. Así que decidí search el cambio pendiente en el repository local y volver a establecerlo en el maestro. Resolví el conflicto.

Después de eso, quise retroceder. Recibí un post de error:

! [remote rejected] HEAD -> refs/for/master (change 166 closed) 

El cambio 166 es la dependencia. Por lo tanto, no puedo rechazar la versión actualizada.

¿Cuál es el método apropiado para deshacerse de las dependencies desactualizadas?

Parece que también has actualizado el CL # 166 e intentando impulsar estos cambios.

Rebase cambia de nuevo y usa git rebase ... -i para elegir las únicas confirmaciones que necesita (es decir, eliminar la línea con 166).