Línea de command de Gradle: no se pudo encontrar el objective android-22

Intento crear un proyecto que saque de un repository de git y todo parece estar instalado correctamente, sin embargo, cuando ejecuto gradle recibo el siguiente post:

FAILURE: Build failed with an exception. * What went wrong: A problem occurnetworking configuring project ':app'. > failed to find target android-22 : /home/rvogel/android-sdk-linux/tools * Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. BUILD FAILED Total time: 7.562 secs 

Luego ejecuté el informe de Android para ver qué objectives había instalado:

 rvogel: ~/StockApp $ android list target Available Android targets: ---------- id: 1 or "android-22" Name: Android 5.1.1 Type: Platform API level: 22 Revision: 2 Skins: HVGA, QVGA, WQVGA400, WQVGA432, WSVGA, WVGA800 (default), WVGA854, WXGA720, WXGA800, WXGA800-7in Tag/ABIs : no ABIs. ---------- 

¿Hay algún otro problema que desencadene esto y no lo estoy encontrando?

ACTUALIZACIÓN: hace time que renuncié a esto, ya que era un proyecto favorito intentar trabajar en una aplicación de Android de forma remota utilizando github para sincronizar el proyecto con una máquina virtual de línea de command. Sin embargo, como puede haber sido capaz de decir, o tal vez no, ya que se marcó como duplicado, no estoy usando Android Studio en la máquina virtual, estoy ejecutando la línea de command del proyecto completo con un IDE en el browser. La pregunta que tengo que haber duplicado es preguntar específicamente acerca de Android Studio a la cual la solución es download la versión correcta de Android. No estoy usando Android Studio y he copydo la printing de mis objectives disponibles, lo que indica que el objective faltante, de hecho, está instalado en la máquina.

Esperando que uses el estudio de Android …

En primer lugar, compruebe el file build.gradle de una aplicación anterior o simplemente cree uno nuevo y consulte el file build.gradle.

Compruebe el file build.gradle de la aplicación que proporciona este problema. Simplemente cámbialo de acuerdo con build.gradle en la aplicación en ejecución.

Básicamente deberás cambiar 2 cosas principales aquí. Mostrado a continuación:

 compileSdkVersion = 21// add the version which is in your running project buildToolsVersion = "21.1.2"/* add the version which is in your running project*/ minSdkVersion = 9 targetSdkVersion = 21/*same as your build.gradle of running app*/ 

Después de los cambios, limpia y reconstruye tu proyecto. Deberia de funcionar.

o

Puede download las versiones sdk requeridas.