la authentication de subversión de Netbeans falló

Hoy comencé a recibir un error extraño, no pude acceder a ningún repository de subversión de mi aplicación Netbeans. Sigo recibiendo authentication fallida.

Estoy usando ubuntu 9.10 y netbeans 6.7.1. Mis cnetworkingenciales están bien, puedo conectarme, actualizarme y comprometerme usando RapidSVN.

Gracias 🙂

Editar más tarde

  • no estoy detrás de un proxy
  • no actualizó la copy de trabajo,
  • el server svn no fue actualizado
  • Lo único diferente es que actualicé mi Linux a Ubuntu 9.10

He encontrado el problema, fue causado porque la contraseña del keyring no estaba configurada, por lo que netbeans no pudo save las cnetworkingenciales, pero por alguna razón la GUI del keyring no se activará para pedir una contraseña.

La solución fue abrir Filezilla que parecía desencadenar la GUI del keyring e ingresar una contraseña para el keyring pnetworkingeterminado, después de eso todo funcionó

Este procedimiento alternativo funcionó para mí en Karmic:

O bien, en un terminal, "rm ~ / .gnome2 / keyrings / login.keyring" sin comillas.

Después de eso, ejecute Ubuntu One, se abrirá el llavero y se le pedirá una nueva contraseña.

¿Usas SvnKit en tu aplicación netbeans?

RapidSVN siempre usa las bibliotecas de subversión estándar, por lo que podría haber una diferencia entre estas dos … especialmente en cómo almacenan las cnetworkingenciales en los almacenes de keys.

Propagablemente, actualizó su copy de trabajo a un formatting más nuevo mediante el uso de RapidSVN.
Intenta verificar tu copy de trabajo nuevamente.

Subversion tiene algunas incompatibilidades entre copys de trabajo de serveres <= 1.5 y 1.6. Ten cuidado. Encontrará más información en las notas de la versión de Subversion.

Ok, tus aclaraciones tacharon mi respuesta. Sin embargo, no lo eliminaré, es probable que otros usuarios puedan usar esta información.