Instalar Subversion de Collabnet obliga a una nueva installation de jdk6

Estoy intentando instalar la última versión de subversión de Collabnet en mi server de Windows. Cuando hago clic en el ícono de configuration aparece un post que dice que necesita instalar la versión 1.6 del entorno de time de ejecución de Java. Muestra que encontró la versión 1.5 en mi máquina.

Tengo ambas versiones 1.5 y 1.6. ¿Cómo puedo hacer que la installation vea la versión 1.6 sin tener que instalar una nueva versión? Revisé mi variable% PATH% y la ruta al 1.6 se incluye como el primer elemento en la ruta.

¿Cómo verifica qué versión está instalada y cómo puedo forzarla a usar la installation 1.6 existente?

Gracias

Editar

Lo siento, olvidé mencionar que también tengo el entorno JAVA_HOME ya configurado y apunta a la versión 1.6.

Editar

Estoy usando Windows Server 2003. Intenté ejecutar java -version desde la command-line y devuelve Java (TM) SE Runtime Environment (compilation 1.6.0_20-b02)

El otro problema que tengo es que la máquina en la que lo estoy instalando no tiene acceso a Internet. Si dejo que Collabnet continúe e instale el JDK, falla porque no puede downloadlo. Así que estoy atascado 🙂

Ok, he logrado resolver el problema. Parece que si está instalando la versión de 64 bits de Collabnet Subversion, se quejará si no encuentra un JDK de 64 bits. Las versiones de JDK que tenía en mi máquina eran ambas de 32 bits JDK.

Instalé el JDK de 64 bits y eso resolvió el problema.

Intente agregar % JAVA_HOME% variable de entorno en lugar de % PATH% . Una vez que haya agregado JAVA_HOME a su sistema, puede intentar instalar CollabNet Subversion de nuevo.

Por ejemplo, tengo la configuration siguiente de la variable JAVA_HOME:

enter image description here

En caso de que haya configurado su JAVA_HOME correctamente, debe poder elegir la ruta jdk durante la installation.