Incapaz de include Proproplyly Showcase View lib

Tengo problemas para include la biblioteca ShowcaseView en mi aplicación Android con Android Studio.

En el repository de GitHub ( https://github.com/Espiandev/ShowcaseView ), dice que debería ser fácil de instalar con Maven. Pero cuando busco showcaseview, Maven no encuentra ningún resultado.

Así que clono el repository en mi computadora y trato de include su carpeta de biblioteca como una biblioteca java en las dependencies de los modules de mi proyecto. Pero cuando bash usarlo en mi código, dice

No se puede resolver el símbolo 'ShowcaseView'

Mi suposition es porque la biblioteca ShowcaseView real no se está comstackndo debido a errores (el repository clonado muestra en varios files el error

No se puede resolver el símbolo 'R'

evento después de agregar NineOldAndroids como una dependencia de module como se muestra en el repository de GitHub.

¿Hay algo que este olvidando?

No debe include la carpeta de la biblioteca como una biblioteca de Java.

intente seguir la forma de agregar la biblioteca ShowcaseView como un module a su proyecto:

Ir a file> Estructura del proyecto …

en el panel izquierdo, select Módulos y en el panel central click el icono más y luego select Importar module del dialog de exploración, select la ruta de la biblioteca ShowcaseView.

click siguiente … para finalizar la import (but notice the directory /gen of library unchecked)

A continuación, vaya a la sección Biblioteca en el panel izquierdo y select libs en el panel central

si la biblioteca robolectric-2.2-20130909.210745-40-jar-with-dependencies.jar existía en el panel derecho, entonces debe eliminarla.

Vaya a la sección Módulos y select su module principal de proyecto en el panel central y click el icono más en el panel derecho y select Module Dependency... luego select la biblioteca ShowcaseView que incluyó previamente.

Ahora deberías rebuild tu proyecto …

Vaya a ShowcaseView Manifest y cambie el nombre del package a com.espiandev.showcaseview the reconstruction, reorganice las importaciones, R se resolvería con el nuevo package.