Importación de proyecto python desde github

Estoy tratando de download este proyecto en python desde github e importarlo a eclipse ubuntu.

El intérprete de python es 3 y noté que después de git clone y ejecutar setup.py , el resultado está en la carpeta python 2.7 lugar de python 3

Y cuando bash import scapy_http.http obtengo una exception (probablemente el intérprete la busque dentro de la carpeta de python 2.7 ).

Cuando trato de replace el intérprete a python 2.7 recibo otra exception en la import scapy.all

  • la import scapy supone venir antes de la import scapy_http

  • Instalé scapy para python 3: pip3 install scapy-python3

Entonces, ¿cómo puedo importar el proyecto scapy-http a mi proyecto Eclipse dado que el intérprete es python 3 ?

Gracias.

Debería estar bien si hicieras pip3 para instalar scary-python3. Es un poco difícil decir exactamente qué está pasando (proporcione posts de error, etc.) pero le sugiero que intente:

 sudo python3 setup.py install 

Si aún no lo has hecho El problema podría ser que dejó el 3 y, por lo tanto, se almacenó en las bibliotecas de python 2.