Implementación continua con Bitbucket en Azure no funciona

Configuré la implementación continua de git con bitbucket en mi website de Azure según este blogpost

Paso por todos los pasos sin ningún problema, pero cuando gito git push para bitbucket, no ocurre ninguna implementación de Azure …

Si presiono mi URL de git azul, la implementación funciona como siempre.

¿Alguien más que haya tenido este problema?

¡Gracias!

Ayer implementamos en bitbucket.org un cambio para enviar el encabezado Authorization con nuestro service POST que puede haber roto nuestra integración con Windows Azure.

He retrocedido el cambio para que podamos investigar.

¿Funciona para ti ahora?

¿Has configurado la implementación de bitbucket después de presionar directamente a tu git repo en Azure? Deberá ingresar y vaciar la carpeta de implementaciones y luego actualizar la pestaña de implementación en el portal. Luego podrá vincular su count de bitbucket de nuevo y debería funcionar entonces

Esta podría no ser la solución en todos los casos, pero para mí es una de las hipótesis que probé y encontré verdadera:

Noté que para los repos privados / públicos donde yo era administrador, la integración se realizaba sin problemas. Es solo para los repos donde tuve acceso de lectura-escritura que no pude configurar la implementación desde el control de la versión (es decir, para los sitios web de Bitbucket y Azure).

En realidad, para probar esta hipótesis, hice una bifurcación de un repository donde solo tengo acceso rw (en la bifurcación, soy administrador automáticamente), y luego intenté configurar el deployment con esta bifurcación. ¡Funcionó bien!

Tenga en count que para todos los repositorys que intenté vincular (ya sea privado o no, y si los enlaces funcionaban o no) tenía acceso de lectura-escritura. Sin embargo, creo que la configuration final solo debería necesitar acceso de lectura a un repository. Todavía tengo que aislar el problema real …