Articles of xcode bots

¿Cambiar las cnetworkingenciales de control de fuente para un Xcode Server Bot?

Seguí las instrucciones de Apple para crear un nuevo bot. Durante uno de los pasos, solicitó las cnetworkingenciales para el sistema de control de origen. Ingresé un nombre de usuario / contraseña sin darme count de que no podría cambiarlo fácilmente en el futuro. ¿Cómo puedo cambiar las cnetworkingenciales que utiliza Xcode Server?

Xcode Bot CI | No se puede encontrar el destino coincidente

Configuré un server Xcode y uso Xcode Bots para hacer CI en mi máquina. (Lo mismo se usa para el desarrollo). Crear un bot para un proyecto, funciona bien. Sin embargo, si agrego el mismo proyecto al espacio de trabajo, (he compartido el esquema – [que está configurado en el contenedor del espacio de trabajo], […]

No se pudo crear un bot en Server 4.0.3

Intento crear un Bot para Mac Server 4.0.3 en OS X 10.10.2. Actualizo el repository de pago con la key SSH existente, pero siempre obtengo el mismo error: "Falló la creación de Bot con error: Error interno al crear Bot". ¿Alguien podría ayudar a resolver este problema o dar alguna explicación de por qué sucedió?

Referencia 'refs / heads / master' no encontrado error

Estoy trabajando con Xcode y GIT para crear un service de compilation automático. Uno de los bots busca en la twig Release cada 5 minutos y la construye en caso de que haya nuevos commits. Recientemente comencé a recibir el siguiente error: Afirmación: no se encuentra la reference 'refs / heads / master' (-9) Este […]

¿Cómo get SHA de confirmación para Xcode Bot "Run Script" Trigger? Actualizando el estado de las testings en Github

Creé un Xcode Bot que se integra en cada commit. En el disparador "Ejecutar script" me gustaría actualizar la confirmación actual de GitHub con el estado de integración de las testings que se ejecutaron. Bastante estándar CI cosas. Entonces ejecutaré un script como el siguiente: curl -i -X POST -H "Content-type: application/json" -H 'Authorization: token […]

Xcode bot: submodules de git no inicializados

Estoy tratando de configurar un bot Xcode con el server OSX. Después de configurar el repository git y crear un bot, ejecuto integrar. No funciona porque el repository se presta solo parcialmente. Más precisamente: de los 6 submodules configurados, solo 3 son inicializados y desprotegidos. didi@mac:/Library/Server/Xcode/Data/BotRuns/Cache/c5fda8f4-4d25-4d25-c18a-eb0b16a06692/source$ git submodule status +c6e8420aec4147641fb1ca12d9f1d31bdd804e77 libs/asi-http-request (v1.7-320-gc6e8420) -ae64a38766b42f236bb94f0e661cddb829f9ac43 libs/kraken -7da02b323636bbaa0bbbf5b4eb229fcc07b1e14a […]

No se pueden crear bots desde el repository alojado en el server de Xcode

Después de crear un nuevo repository en mi Xcode Server , no puedo acceder a él mediante ssh , pero puedo realizar tanto el command git clone command git push usando el protocolo https . Además encuentro el siguiente error cuando bash crear un Xcode Bot : Oct 25 12:43:46 mokii.com xcsbuildd[99898]: XCSCheckoutIntegrationStep.m:160 [XCSCheckoutIntegrationStep logUnderlyingErrorForError:] […]