Articles of rubygems

¿Por qué tengo este error de Ruby On Rails cuando quiero instalar wkhtmltopdf-binary?

Estoy desarrollando entornos Ubuntu 16.04 y tengo esta salida. $ gem install wkhtmltopdf-binary -v '0.12.3.1' ERROR: Error al instalar wkhtmltopdf-binary: gem no válido: el package está dañado, exception al verificar: método indefinido `size 'para nil: NilClass (NoMethodError) en /home/user/.rvm/gems/ruby-2.3.1/cache/ wkhtmltopdf-binary-0.12.3.1.gem

mejores prácticas de versionado para gems de Ruby

Tengo un proyecto actualmente en producción pero aún se está desarrollando activamente. Estoy agregando nuevas gems y funcionalidades a menudo. antes de mi último lanzamiento, parte de mi código se rompió en mi entorno de desarrollo y descubrí que se debía a que algunas de mis gems (CarrierWave y jQuery en particular) habían sido actualizadas […]

Cómo crear `nuevo proyecto jekyll` con la versión jekyll específica en Windows 7

Tengo Ruby 2.1.6 y 2.1.7 instalados en mi PC (Win 7 x64 SP1) y uso uru para cambiar entre ellos. Ellos trabajan bien. También he instalado algunas versiones de Jekyll: 2.4.0, 2.5.3, 3.0.2 y 3.1.1. Trabajo con algunos proyectos de jekyll sin ningún problema. Ahora, para reproducir un website muy específico, necesito crear un jekyll […]

¿Hay una gem de Ruby que difiere entre los documentos HTML?

Hacer una diferencia de dos documentos html diferentes resulta ser un problema completamente diferente que simplemente hacer una diferencia de text sin formatting. Por ejemplo, si hago una diferencia LCS ingenua entre: Google</p> y Google</a></p> el resultado diff no es: </a> pero /a></ He probado la mayoría de las gems que pretenden ser html diff, […]

¿Cómo cambiar la versión del bundler que se usa en los Rails?

Cuando ejecuto el siguiente command, me da las versiones instaladas disponibles de bundler: command: gem list | grep "bundle" salida: bundler (1.11.2, 1.10.6, 1.10.4, 1.3.6, 1.3.0, 1.3.0.pre) La versión actual de bundler que obtuve fue 1.11.2 usando el siguiente command: bundler –version Quiero usar la versión 1.3.6. ¿Cómo cambio la versión actual del package con […]

Creando un server de gems, al cual puedo liberar gems

He escrito algunas gems que he lanzado a rubygems usando Gemcutter y la fuente almacenada en github. Tengo el problema de que necesito crear una joya que no pueda ser de código abierto y que tampoco esté disponible para la comunidad, sino solo para los miembros de mi equipo. Soy consciente de que puedo almacenar […]

Bundler no pudo encontrar versiones compatibles para gem

He agregado una gem 'koala' a mi Gemfile y parece haber descartado las versiones de gem cuando ejecuto el command 'bundle install': Bundler could not find compatible versions for gem "faraday": In snapshot (Gemfile.lock): faraday (0.6.1) In Gemfile: koala (~> 1.2.0beta1) depends on faraday (~> 0.7.4) Running `bundle update` will rebuild your snapshot from scratch, […]

Cómo acceder a svn repo usando ruby ​​en svn_wc

Estoy usando svn_wc. Da error, ya que no hay tal file para cargar – svn / core (LoadError) ¿qué hacer?

Requiere gem en horquilla en package

Tuve que bifurcar una gem de github y hacer algunos cambios de código para satisfacer mis necesidades. Luego lo puse en mi propio repository github usando este recurso . Ahora, para mi aplicación, agregué la gem a mi Gemfile : source 'https://rubygems.org' gem 'openvas-omp', :git => 'git://github.com/godzilla74/openvas-omp-ruby.git' Ran la bundle install y ahora estoy tratando […]

No se puede instalar Ruby Gems desde GitHub usando bundler

Estoy tratando de instalar varios files gem desde varios repositorys GitHub usando bundler (el command "bundle install"). Por ejemplo, una de las líneas de mi Gemfile es: gem 'mongoid_search', git: 'https://github.com/mauriciozaffari/mongoid_search.git', branch: 'master' Sin embargo, cuando ejecuto "package de installation", parece ahogarse al almacenar en caching los files. Recibo el siguiente error de bundler: Fetching […]