Articles of npm install

Errores al intentar ejecutar la documentation de Bootstrap localmente

En primer lugar, estoy usando el siguiente entorno: Sistema operativo: Windows 7 npm: 3.10.10 nodo: 6.9.4 ruby: 2.2.6p396 y los siguientes son mis pasos para ejecutar la documentation localmente Tenedor bootstrap github repo clonarlo sigue todos los pasos para instalar jekyll, ruby ​​como usuario de Windows en la window de cmd, vaya a la ruta […]

GIT – Compromiso disponible en git repo pero no se muestra en el repository local

Estoy teniendo un problema en la installation de NPM ahora. Estoy teniendo un valor en package.json como este "angular-dynamic-locale": "git://github.com/xxxx/angular-dynamic-locale" y de manera similar algunos otros valores también son así en el file. Después de hacer la installation de NPM, recibo un error como este npm ERR! git rev-list -n1 2bebf3223b7b9ab00a18e294a52bcfffbbe066b7: fatal: bad object 2bebf3223b7b9ab00a18e294a52bcfffbbe066b7 […]

npm ignora "git +" durante la installation de npm

Tengo varias dependencies en package.json especificadas como enlaces directos a los repos de github: "dependencies": { // omitted "gaze": "git+https://github.com/chebum/gaze.git", } Cuando pago el proyecto y npm install , se npm install una versión de la mirada del repository global de npm, no de mi repo de github. Puedo confirmarlo mirando el código fuente de […]

La installation de NPm y el maestro de origen de git push no funcionan

npm install jquery no funciona Por favor, busque la captura de pantalla a continuación: Después de eso, el maestro de origen de git push no funciona

require () en nodeJS no funciona con un module que acabo de instalar

Estoy tratando de trabajar con node.js por primera vez. Pero sigo encontrando el mismo problema una y otra vez. Quiero instalar un module de github. Si bash instalarlo desde Internet, sigo recibiendo advertencias y errores. Guarde el file zip y extráigalo en mi escritorio e instálelo desde allí. Creo que funciona como se ve en […]

¿Por qué no se pudo instalar angular / cdk?

Soy nuevo en Angular2. Estoy intentando ejecutar este command: – npm install –save angular / cdk por alguna razón, me pidió un nombre de usuario y una contraseña. No estoy seguro de si ese es el usuario del sistema / pwd o el de Github. De todos modos entré si estaba mal. Ahora bien, cuando […]

npm crea sin errores pero no funciona

Soy nuevo en NPM y node.js Intenté ejecutar este proyecto de MIT https://github.com/quran/quran.com-frontend Seguí las instrucciones del desarrollador 0-npm install dotenv –save 1- update the API_URL, in development.env file, from localhost to api.quran.com 2-To start the app,run ====> npm run dev 3- Go to http://localhost:8001 in your browser Algunas veces recibo este post de advertencia […]

Cómo instalar npm para trabajar en github

Soy nuevo en github . Quiero instalar npm para trabajar con el nodo js . Pero al instalar npm recibo el siguiente error. Cloné mi proyecto de GitHub. Después de que se realiza la clonación, necesito instalar npm para build mi proyecto. Pero no estoy logrando instalar el npm . Cualquier persona por favor sugiere […]

package npm de github, files perdidos

Estoy tratando de hacer reference a logary-js de un proyecto mío. Tengo este file packages.json: … "dependencies": { "logary": "logary/logary-js#master", … } … Sin embargo, al intentar desplegar el package, falla con este error: ✗ npm install > logary@1.0.0 preinstall /Users/h/dev/proj/node_modules/.staging/logary-6603d70a > npm run build > logary@1.0.0 build /Users/h/dev/proj/node_modules/.staging/logary-6603d70a > NODE_ENV=production webpack –progress –color –display-error-details […]

Instalación / dependencia de NPM desde un Binary de versión de GitHub

Sé cómo hacer una dependencia de NPM desde una versión de GitHub: "dependencies": { "package-name": "user/repo#v1.0.0" } Eso es bueno, pero quiero instalar un binary específico de esta versión. Lo intenté "dependencies": { "package-name": "https://github.com/user/repo/releases/download/v1.0.0/bin.tgz" } Pero me da el siguiente error: ❯ npm install npm ERR! fetch failed https://github.com/user/repo/releases/download/v1.0.0/bin.tgz npm WARN retry will retry, […]