Articles of laravel 4

Cómo hacer que Laravel, Composer y SVN trabajen juntos

Me estoy sintiendo muy frustrado con la forma en que Laravel 4 y Composer trabajan con SVN. Quizás hay algo que estoy pasando por alto. Mi flujo de trabajo consiste en desarrollar localmente y luego cargarlo en un server DEV, usamos beanstalk ( http://beanstalkapp.com/ ) como nuestro sistema de implementación y control de versiones en […]

Laravel 4 database.php no puede acceder a DB

Tengo una aplicación laravel4 trabajando en mi computadora de trabajo. Recientemente descargué los files a través de svn en la máquina de mi casa y cuando bash abrir el proyecto en el browser, aparece el siguiente error: ErrorException (E_UNKNOWN) SQLSTATE[HY000] [1045] Access denied for user 'root'@'localhost' (using password: YES) (View: C:\wamp\www\xzy.tld\app\views\layout.blade.php) (View: C:\wamp\www\xyz.tld\app\views\layout.blade.php) Este es […]

Laravel: argumento no válido proporcionado foreach ()

Trabajar con un proyecto que utiliza el logging de usuarios de OAuth a través de GitHub. Todo funciona bien hasta el último paso de confirmación de la count a través de mi aplicación. Aquí está la function en cuestión: /** * Get the primary, verified email address from the Github data. * * @param mixed […]

Tiene problemas para instalar barryvdh / laravel-ide-helper a través del compositor – error de class no encontrada en el proyecto Laravel 4

Tengo el siguiente file composer.json para mi proyecto Laravel 4.2.x : { "name": "laravel/laravel", "description": "The Laravel Framework.", "keywords": ["framework", "laravel"], "license": "MIT", "type": "project", "require": { "laravel/framework": "4.2.*", "cartalyst/sentry": "2.1.*", "way/generators": "2.*", "laracasts/flash": "~1.0", "guzzlehttp/guzzle": "~4.0", "itsgoingd/clockwork": "1.*", "barryvdh/laravel-ide-helper": "~1.11@dev", "intervention/image": "dev-master" }, "autoload": { "classmap": [ "app/commands", "app/controllers", "app/models", "app/database/migrations", "app/database/seeds", "app/tests/TestCase.php" ], […]

Autenticación de Github usando php-github-api

Estoy tratando de implementar la authentication Github en mi aplicación (construida usando Laravel 4) usando php–github–api por KnpLabs. Seguí adelante y creé una aplicación en mi count de Github para get el client_id y la key secreta. El problema es que no puedo autenticar usando esta biblioteca. Se devuelve un resultado nulo. Su implementación parece […]

Laravel crea un problema de proyecto

Aunque el command de composer install funcionó bien, no pude crear un nuevo proyecto porque encontré el siguiente error con respecto a GIT. Alguna solución ?

Fallo en la actualización de Laravel4 Composer

Estoy trabajando en un proyecto Laravel 4. Cuando trato de actualizar mis packages con Composer, llega a doctrine / collections pero arroja este error: [Runtime Exception] Failed to execute git status –porcelain –untracked-files=no error: bad index file sha1 signature fatal: index file corrupt Trazado de exception: http://pastebin.com/Js3nKrhy Intenté eliminar el índice en doctrine / collections […]

Compositor no actualiza la biblioteca requerida

Estoy usando el framework Laravel y quería include una biblioteca de GitHub. Este es mi file completo composer.json : { "name": "laravel/laravel", "description": "The Laravel Framework.", "keywords": ["framework", "laravel"], "license": "MIT", "require": { "laravel/framework": "4.0.*", "intervention/helper": "dev-master" <- this is what I've added }, "autoload": { "classmap": [ "app/commands", "app/controllers", "app/models", "app/validators", "app/database/migrations", "app/database/seeds", "app/tests/TestCase.php" […]

por qué boostrap / start.php no está en gitignore (laravel)

Me he preguntado por qué boostrap / start.php no está en git ignorar … Bueno, no quiero confirmar la contraseña de db con el repository, así que lo escribiré en .env.local.php y luego lo accederé a través de $ _ENV en database.php, pero necesito definir el nombre de host en bootstrap / start.php Pero estoy […]

Sentry por error de Laravel

Estoy trabajando con un socio remoto para desarrollar un proyecto Laravel. No tenía instalado mcrypt, por lo que estaba haciendo reference a php por alias cada vez que necesito usar compositor: alias php='/Applications/MAMP/bin/php/php5.5.3/bin/php' Esta fue una solución correcta hasta que mi amigo remoto instaló el package Sentry, lo que no pude hacer. Usando otro hilo […]