Articles of bundler

No se puede instalar Ruby Gems desde GitHub usando bundler

Estoy tratando de instalar varios files gem desde varios repositorys GitHub usando bundler (el command "bundle install"). Por ejemplo, una de las líneas de mi Gemfile es: gem 'mongoid_search', git: 'https://github.com/mauriciozaffari/mongoid_search.git', branch: 'master' Sin embargo, cuando ejecuto "package de installation", parece ahogarse al almacenar en caching los files. Recibo el siguiente error de bundler: Fetching […]

Aparente conflicto entre el empaquetador y el RVM

Estoy usando rvm con un gemset para un proyecto de Rails. Normalmente, las gems instaladas se colocan en la carpeta my_gemset / gems, sin embargo, parece que las gems de github se ponen en my_gemset / bundler / gems. Sin embargo, debido a que hay un file con el package de nombre en la carpeta […]

Descargar todas las gems y dependencies de github o un server separado en lugar de RubyGems?

Las networkinges de mi empresa no nos permitirán acceder a casi cualquier sitio, excepto github, así que me pregunto cómo podré instalar las gems. Opción 1: apunta a la fuente github de todas las gems, pero ¿no deberíamos también especificar las dependencies de github también? Opción 2: Tenemos un server proxy que tiene acceso a […]

remoto: repository no encontrado después de actualizar el token oauth

Después de actualizar mi token de acceso personal github, que utilizo para autenticar una gem de un repository privado, el package sigue diciéndome: remote: Repository not found fatal: repository 'https://MY_OAUTH_TOKEN:x-oauth-basic@github.com/me/my_repo.git/' not found La gem se especifica en el Gemfile como siempre he hecho, con commit ref y url (y branch). Traté de eliminar la carpeta […]

¿Cómo puedo hacer que 'package de installation' siempre descargue una gem alojada de forma privada (en Github)?

Tenemos una joya que contiene código compartido para múltiples aplicaciones. Está alojado en un repository privado de github. Quiero que cada aplicación agarre automáticamente la última versión de esa gem cada vez que se ejecute la bundle install , por lo que es fácil para los demás miembros de mi equipo estar siempre actualizados, además […]

bundle install funciona, pero bundle-show da error "rails.git aún no está desprotegido. Ejecute `package de installation`"

Recientemente he actualizado nuestro Gemfile para usar una copy en bifurcación en nuestra count de github. Hemos creado una twig personalizada fuera de la twig estable de 2.3 (a la que llamaré the_bugfix_branch ) y he añadido gemspecs para cada una de las gems para que sean identificables por bundler. My Gemfile tiene lo siguiente: […]

¿Cómo descifra Bundler qué compromiso corresponde a una determinada versión de Gema?

He estado investigando la página de Bundler y la página de RubyGem (y las publicaciones de SO) pero parece que no puedo resolver esto. En el Gemfile, usted especifica a Bundler qué versión de la Gema usar. Eso es todo lo que sé que es cierto … el rest es que adivino lo que sucede […]

no se pueden encontrar los files joya bifurcados de github repo

Estoy usando rails v 3.2.12 y jQuery plyg-in estándar como una gem. Ahora necesito hacer algunos cambios en él, así que bifurqué github repo para hacer lo que necesito y luego instalé la gem y la uso, y el problema está en el último paso. Escribo en mi gemfile gem 'fullcalendar-rails', :git => 'https://github.com/mitchenkod/fullcalendar-rails-kogdata.git' la […]

Jekyll no se comstackrá si existe el file gemfile

Estoy trabajando en mi sitio de Github Pages, así que necesito comstackrlo en mi máquina local. Siguiendo sus instrucciones , lo he configurado usando bundler. Sin embargo, bundler parece romper la compilation de Jekyll. Si jekyll new NewSite , crea un nuevo sitio que se puede build utilizando el jekyll serve . Sin embargo, tan […]

¿Cómo instalar gem / plugin en rails3 cuando no se encuentra en rubygems?

Quiero instalar la gem simple-posts privados (http://agilewebdevelopment.com/plugins/simple_private_messaging), https://github.com/jongilbraith/simple-private-messages . Agregué a mi Gemfile: gem 'simple-private-messages' Pero consigue el error: Fetching source index for http://rubygems.org/ Could not find gem 'simple-private-messages (>= 0)' in any of the gem sources listed in your Gemfile. Luego intenté modificar Gemfile para: gem 'simple-private-messages', :git => 'git://github.com/professionalnerd/simple-private-messages.git' pero consigue el error: […]