Git no trabaja en el leopardo de las nieves

Instalé correctamente git en mi Mac (Snow Leopard 10.6.8), pero no puedo hacer que ninguno de los commands funcione. Todo lo que escribo en la terminal escupe illegal instruction .

Por ejemplo:

 git --version Illegal instruction 

Nota: Esta descarga se adaptó a Snow Leopard como se ve en el file Léame que proporcionaron. Entonces no tengo idea de por qué esto es tan doloroso.

 NOTES ABOUT THIS BUILD ============ * This build targets Snow Leopard and Lion. It may work on earlier or later versions of OS X. 

He intentado instalar homebrew , pero eso no funciona porque no puede encontrar Xcode que tampoco puedo get en mi computadora.

¿Alguien sabe por qué git no funciona en Snow Leopard?

Parece que estás ejecutando esto en una Mac con un procesador Core Duo. La versión de Git que instaló necesita un Core 2 Duo.