Git no funciona para el tutorial angularjs.org

Estoy intentando seguir el tutorial de angularjs.org ( https://docs.angularjs.org/tutorial ). Requiere que instales y configures git y estoy teniendo problemas para hacer que todo funcione. Las instrucciones en el tutorial son bastante sencillas, así que no estoy seguro de dónde podría haber salido mal. Todas las opciones pnetworkingeterminadas fueron seleccionadas durante la installation.

Los problemas comienzan después de instalar node.js y TRATANDO de instalar todas las herramientas necesarias para el proyecto. Intenté esto tanto en la command-line de git como en git bash (no estoy seguro de cuál es la diferencia). Después de instalar node.js, el tutorial dice que pongas el command npm install para las otras herramientas y en git bash obtienes esto

 > bufferutil@1.2.1 install C:\Users\Ivan\angular-phonecat\node_modules\bufferutil > node-gyp rebuild C:\Users\Ivan\angular-phonecat\node_modules\bufferutil>if not defined npm_config_node_gyp (node "C:\Program Files\nodejs\node_modules\npm\bin\node-gyp-bin\\..\..\node_modules\node-gyp\bin\node-gyp.js" rebuild ) else (node "" rebuild ) gyp ERR! configure error gyp ERR! stack Error: Can't find Python executable "python", you can set the PYTHON env variable. gyp ERR! stack at failNoPython (C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\lib\configure.js:401:14) gyp ERR! stack at C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\lib\configure.js:356:11 gyp ERR! stack at FSReqWrap.oncomplete (fs.js:82:15) gyp ERR! System Windows_NT 6.1.7601 gyp ERR! command "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\node_modules\\node-gyp\\bin\\node-gyp.js" "rebuild" gyp ERR! cwd C:\Users\Ivan\angular-phonecat\node_modules\bufferutil gyp ERR! node -v v5.6.0 gyp ERR! node-gyp -v v3.2.1 gyp ERR! not ok npm WARN install:bufferutil@1.2.1 bufferutil@1.2.1 install: `node-gyp rebuild` npm WARN install:bufferutil@1.2.1 Exit status 1 > utf-8-validate@1.2.1 install C:\Users\Ivan\angular-phonecat\node_modules\utf-8-validate > node-gyp rebuild C:\Users\Ivan\angular-phonecat\node_modules\utf-8-validate>if not defined npm_config_node_gyp (node "C:\Program Files\nodejs\node_modules\npm\bin\node-gyp-bin\\..\..\node_modules\node-gyp\bin\node-gyp.js" rebuild ) else (node "" rebuild ) gyp ERR! configure error gyp ERR! stack Error: Can't find Python executable "python", you can set the PYTHON env variable. gyp ERR! stack at failNoPython (C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\lib\configure.js:401:14) gyp ERR! stack at C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\lib\configure.js:356:11 gyp ERR! stack at FSReqWrap.oncomplete (fs.js:82:15) gyp ERR! System Windows_NT 6.1.7601 gyp ERR! command "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\node_modules\\node-gyp\\bin\\node-gyp.js" "rebuild" gyp ERR! cwd C:\Users\Ivan\angular-phonecat\node_modules\utf-8-validate gyp ERR! node -v v5.6.0 gyp ERR! node-gyp -v v3.2.1 gyp ERR! not ok npm WARN install:utf-8-validate@1.2.1 utf-8-validate@1.2.1 install: `node-gyp rebuild` npm WARN install:utf-8-validate@1.2.1 Exit status 1 > angular-phonecat@0.0.0 postinstall C:\Users\Ivan\angular-phonecat > bower install npm WARN optional Skipping failed optional dependency /chokidar/fsevents: npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.0.7 

Ahora probé esto en Git CMD primero y obtuve algo así como npm WARN deprecated graceful-fs@3.0.8: graceful-fs version 3 and before will fail on newer node releases. Please update to graceful-fs@^4.0.0 as soon as possible. npm WARN deprecated graceful-fs@3.0.8: graceful-fs version 3 and before will fail on newer node releases. Please update to graceful-fs@^4.0.0 as soon as possible. Lo intenté de nuevo en Git CMD y ahora obtengo lo que parece ser lo mismo que sucedió en bash. Tengo la versión del nodo 5.6.0.

¿Alguien sabe a dónde debo ir desde aquí?

ACTUALIZAR

De acuerdo, terminé haciendo la corrección publicada por @Oliver Queen, excepto que hice la npm install desde GIT Bash en lugar de SDK 7.1 (SDK no pudo encontrar el directory donde guardé el proyecto, creo que porque recuerdo que durante la npm install de GIT opción sobre solo poder usar Git Bash y no Windows cmd?). Parece que funcionó, esto es lo que obtuve

 $ npm install > bufferutil@1.2.1 install C:\Users\Ivan\angular-phonecat\node_modules\bufferuti l > node-gyp rebuild C:\Users\Ivan\angular-phonecat\node_modules\bufferutil>if not defined npm_config _node_gyp (node "C:\Program Files\nodejs\node_modules\npm\bin\node-gyp-bin\\..\. .\node_modules\node-gyp\bin\node-gyp.js" rebuild ) else (node "" rebuild ) Building the projects in this solution one at a time. To enable parallel build, please add the "/m" switch. bufferutil.cc win_delay_load_hook.c Creating library C:\Users\Ivan\angular-phonecat\node_modules\bufferutil\bui ld\Release\bufferutil.lib and object C:\Users\Ivan\angular-phonecat\node_modules \bufferutil\build\Release\bufferutil.exp Generating code Finished generating code bufferutil.vcxproj -> C:\Users\Ivan\angular-phonecat\node_modules\bufferutil\b uild\Release\\bufferutil.node > utf-8-validate@1.2.1 install C:\Users\Ivan\angular-phonecat\node_modules\utf-8 -validate > node-gyp rebuild C:\Users\Ivan\angular-phonecat\node_modules\utf-8-validate>if not defined npm_co nfig_node_gyp (node "C:\Program Files\nodejs\node_modules\npm\bin\node-gyp-bin\\ ..\..\node_modules\node-gyp\bin\node-gyp.js" rebuild ) else (node "" rebuild ) Building the projects in this solution one at a time. To enable parallel build, please add the "/m" switch. validation.cc win_delay_load_hook.c Creating library C:\Users\Ivan\angular-phonecat\node_modules\utf-8-validate \build\Release\validation.lib and object C:\Users\Ivan\angular-phonecat\node_mod ules\utf-8-validate\build\Release\validation.exp Generating code Finished generating code validation.vcxproj -> C:\Users\Ivan\angular-phonecat\node_modules\utf-8-valida te\build\Release\\validation.node > angular-phonecat@0.0.0 postinstall C:\Users\Ivan\angular-phonecat > bower install angular-phonecat@0.0.0 C:\Users\Ivan\angular-phonecat `-- protractor@2.5.1 `-- selenium-webdriver@2.47.0 `-- ws@0.8.1 +-- bufferutil@1.2.1 | +-- bindings@1.2.1 | `-- nan@2.2.0 `-- utf-8-validate@1.2.1 `-- nan@2.2.0 npm WARN optional Skipping failed optional dependency /chokidar/fsevents: npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.0.7 

Como puedes ver en la parte inferior, sigo recibiendo

 npm WARN optional Skipping failed optional dependency /chokidar/fsevents: npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.0.7 

¿Debo preocuparme por esto?