Error DNS de TSVN: el nombre solicitado es válido, pero no se encontraron datos del tipo solicitado

Actualicé mi cliente de TortoiseSVN y ahora recibo el error cuando trato de actualizar o comprometerme con diferentes repositorys:

El nombre solicitado es válido, pero no se encontraron datos del tipo solicitado

¿Alguna idea sobre cómo puedo resolver esto? Internet Explorer muestra la URL adecuada sin problemas.

TortoiseSVN 1.5.3, Build 13783.

Estaba luchando para resolver este problema … por fin encontré una solución …

en la URL proporcionada, brinde la dirección IP en vez de ServerName

por ejemplo: ' http: //xxx.xxx.xx: 8080 / svn / RepositoryName '

Tengo el problema solucionado al hacer esto …

Espero que esta información ayude

Este error que se informa es winsock, en lugar de ser particular de TSVN. De los códigos de error de Windows Sockets :

El nombre solicitado es válido y se encontró en la database, pero no tiene los datos asociados correctos que se resuelven, p. Ej., Se devuelve un logging MX pero no un logging A, lo que indica que el server existe, pero no se puede acceder directamente.

Sin embargo, es extraño que puedas acceder al host a través de IE. ¿Es posible que en TSVN haya especificado un número de puerto que no está disponible en el host remoto, y IE está accediendo al host en el puerto 80?

¿Cambió el protocolo de connection (por ejemplo, de svn a http o de http a https)? ¿O cambió alguna configuration de firewall entre su PC y el server SVN? SVN sobre HTTP usa verbos DAV para realizar acciones, por lo que es posible que estén bloqueados en un firewall.

Me doy count de que este es un hilo viejo, pero acabo de experimentar el mismo problema y encontré una solución para no dañar el intercambio.

La solución para mí implicó establecer las configuraciones de proxy apropiadas dentro de TortoiseSVN | Configuración | Network (que ya estaban configurados en mi browser, por lo tanto, puedo ver el repository allí). Entonces, si está detrás de un server proxy, asegúrese de configurar TortoiseSVN adecuadamente.

Chicos, gracias por sus respuestas. Todo fue arreglado por otro reinicio (2 reinicios después de la actualización de TSVN).

Todavía no puedo explicar lo que pasó. 🙂

Obtuve este error al intentar ejecutar TeamCity y Visual SVN Server en la misma PC virtual. El cambio de los services de TeamCity resolvió el problema para mí. Es posible que los dos serveres web estuvieran teniendo problemas entre ellos.

He intentado todas las soluciones, pero la mezcla de ellas funcionó.

  1. Borre todas las líneas válidas en C: \ Usuarios \% NOMBRE DE USUARIO% \ AppData \ Subversion \ servers
  2. Borre todas las líneas válidas en C: \ ProgramData \ Subversion \ servers
  3. Abre TortoiseSvn -> networking y desmarca la opción "habilitar server proxy"

trabajó para mi. Buena suerte 🙂

Tenía una IP estática que no generaba ningún server DNS. Configura tu IP a DHCP y te ayudará.