Error después de agregar un repository en build.grade

Estoy agregando un repository en mi build.grade pero tan pronto como click "sincronizar ahora" muestra los errores:

Error: no se pudo resolver: com.android.support:appcompat-v7:26.0.1 Instalar el repository y el proyecto de synchronization
Abrir documento
Mostrar en el dialog de Estructura del proyecto Error: Error al resolver: com.android.support:recyclerview-v7:26.0.1 Instalar el repository y el proyecto de synchronization
Abrir documento
Mostrar en el dialog Estructura del proyecto

Este es el repository que bash agregar

compile 'com.afollestad.material-dialogs:core:0.9.4.7' 

Mi build.grade (Módulo: aplicación)

 ext{ supportVersion = "26.0.0-alpha1" } dependencies { compile fileTree(include: ['*.jar'], dir: 'libs') androidTestCompile('com.android.support.test.espresso:espresso- core:2.2.2', { exclude group: 'com.android.support', module: 'support- annotations' }) compile "com.android.support:appcompat-v7:${supportVersion}" compile "com.android.support:recyclerview-v7:${supportVersion}" testCompile 'junit:junit:4.12' compile "com.android.support:design:${supportVersion}" compile 'com.simplecityapps:recyclerview-fastscroll:1.0.16' compile 'com.github.bumptech.glide:glide:3.8.0' compile "com.android.support:palette-v7:${supportVersion}" compile 'com.afollestad.material-dialogs:core:0.9.4.7' } 

Después de eliminar el repository que bash agregar, no aparece ningún error. Gracias.

Espero usar lleno

  repositories { jcenter() maven { url "https://maven.google.com" } }