Error de SVN en eclipse con operación de borrado (aparentemente)

Tengo un proyecto de Android en Eclipse (STS) y me está dando este error la última vez que traté de comstackr:

The project was not built due to "SVN: '0x00000119: Delete' operation finished with error". Fix the problem, then try refreshing this project and building it since it may be inconsistent

Google no fue muy útil. Solo 9 hits

Descartaría su proyecto actual y volvería a generar los files del proyecto de nuevo, importando la base de código 🙁

Actualización: JohnEye recomienda intentar primero una limpieza svn y esto puede resolver su problema. Si no, mira arriba.

Tuve el mismo problema, desconecté y conecté el proyecto desde el SVN. En el proyecto, haz clic con el button derecho, EQUIPO> Desconectar y se solucionó el problema

Es posible que haya encontrado la respuesta. Es sorprendentemente simple, suponiendo que esté usando Linux, navegue hasta el directory del proyecto ( cd ~/workspace/myProject ) y ejecute svn cleanup

Resolvió el problema para mí.

Editar: Me acabo de pasar y mi solución funcionó como se esperaba, por lo que probablemente no fue solo un golpe de suerte aleatorio.

Tenía el mismo problema. La solución fue desconectar el proyecto de SVN (Team-> Disconnect) (nota: asegúrese de no eliminar .svn) y actualizar el proyecto. Vuelves a la normalidad y puedes volver a conectarte a SVN una vez más.

Eliminar el proyecto y volver a verificar ha funcionado durante un par de horas, pero luego el problema volvió (tal vez borré cosas otra vez o lo que sea). Hay una pista de error aquí: http://issues.tmatesoft.com/issue/SVNKIT-77

SVN es una herramienta maravillosa, si se usa correctamente. Lamentablemente, cuando utilizamos SVN incorrectamente, nos topamos con problemas tan locos.

La mejor manera de solucionar problemas como este,

  1. Proyecto de pago de nuevo
  2. Utilice meld y copie "SOLAMENTE" files, NO "directorys" del espacio de trabajo a la carpeta de pago.

Si copys carpetas, también terminarás copyndo .svn carpetas ocultas y estarás en el mismo lío de nuevo. Entonces crea las carpetas manualmente.

Una más, NO pierdas tu time tratando de encontrar forms de arreglar tus problemas svn. Simplemente use el process de 2 pasos anterior.

Me encontré con el mismo problema después de importar el proyecto del repository bitbucket. Lo que funcionó para mí fue desconectar el proyecto y conectarlo de nuevo.

  1. Team->disconnect. 2. Team->share project->Git->Use or create repository in parent folder->finish