Error de installation de SDK de Cloudbees para Eclipse Indigo SR2

Trabajar con el SDK desde mi línea de command en mi linux box está bien.
Pero sé que quiero usar el complemento provisto para Eclipse. Tengo Eclipse Indigo versión SR2 Build id: 20120216-1857 .
He instalado egit scm versión 1.3.0.2 con jgit.
Utilizo el siguiente enlace como ruta de installation: http://eclipse.cloudbees.com para el plugin cloudbees.
Tenga en count que la última versión de e-git no funciona con Eclipse Indigo. Así que instalé egit desde el siguiente enlace de la versión compatible: http://download.eclipse.org/egit/updates-1.3 . Así que enciendo el software de installation para cloudbees y mientras trata de descubrir dependencies, no puede instalar el complemento debido a:

No se puede completar la installation porque no se encontraron uno o más elementos necesarios. Software que se está instalando: CloudBees Toolkit 2.0.2.201307232010 (com.cloudbees.eclipse.feature.group 2.0.2.201307232010) Requisito faltante: CloudBees SCM Egit 2.0.2.201307232010 (com.cloudbees.eclipse.dev.scm.egit 2.0.2.201307232010) requiere ' package org.eclipse.jgit 2.3.0 'pero no se pudo encontrar No se puede satisfacer la dependencia: From: CloudBees Toolkit 2.0.2.201307232010 (com.cloudbees.eclipse.feature.group 2.0.2.201307232010) Para: com.cloudbees.eclipse.dev .scm.egit [2.0.2.201307232010]

Claramente no puedo porque hay una falla en las versiones requeridas de que egit for cloudbees funcione. El problema es que el plugin egit que tengo es diferente al requerido. Por lo tanto, las dos posibilidades son:

  • De alguna manera instalar la versión 2.0.2 de Egit … que no creo que sea el caso.
  • ¿Alguien probó correctamente las versiones de egit compatibles en indigo sr2 y cloudbees sdk?

De acuerdo con el post de error, necesita la versión 2.3.0 o posterior de EGit.

EGit 2.3.0 funciona bien con Eclipse Indigo SR2 y con el último CloudBees Toolkit.

"2.0.2" del post de error es la versión de CloudBees Toolkit.

EGit 2.3.x es compatible con Eclipse Indigo SR2 siempre que EGit Import Support no esté instalado. Consulte http://wiki.eclipse.org/EGit/FAQ#What_versions_of_Eclipse_does_EGit_target.3F para get la list de versiones de EGit compatibles para una versión específica de Eclipse.

Descubro la solución … el problema es que si decides instalar las siguientes instalaciones desde el mercado, fallará, porque la versión de egit 3.2 no es compatible con eclipse indigo sr2, especialmente la funcionalidad Importar origen hace que el eclipse se bloquee. La forma de instalar el complemento Cloudbees en índigo es simple.

Utilice el siguiente enlace para instalar Egit: http://download.eclipse.org/egit/updates-2.3 En los complementos que se includeán, solo agregue la funcionalidad básica de Egit y JGit. Instalar y reiniciar Luego, a través del mercado, instale cloudbees eclipse plugin.Est voila. El problema no proviene de Cloudbees en sí, sino que arroja una dependencia indirecta que falla.

respetos \ n \ m