Error de extensión nativa después de instalar Git & Heroku

He estado buscando una solución desde ayer y todo lo que he probado conduce a un callejón sin salida.

Nuevo en RoR y caminando a través de tutoriales. Todo estaba funcionando bien, hasta que comencé a configurar GIT y Heroku. Tuve que instalar jruby_windows y heroku-toolbelt, y creo que esto estropeó las cosas.

Ahora cuando ejecuto bundle install , recibo los siguientes errores de salida

 \BookReview>bundle install Fetching gem metadata from https://rubygems.org/........... Fetching version metadata from https://rubygems.org/... Fetching dependency metadata from https://rubygems.org/.. Resolving dependencies........ Using rake 11.2.2 Using i18n 0.7.0 Using json 1.8.3 Using minitest 5.9.0 Using thread_safe 0.3.5 Using builder 3.2.2 Using erubis 2.7.0 Using nokogiri 1.6.8 Using rack 1.6.4 Using mime-types-data 3.2016.0521 Using arel 6.0.3 Using execjs 2.7.0 Using bcrypt 3.1.11 Using bcrypt-ruby 3.0.1 Using debug_inspector 0.0.2 Using sass 3.4.22 Using bundler 1.12.5 Installing byebug 9.0.5 with native extensions C:/jruby-9.0.0.0/lib/ruby/stdlib/rubygems/ext/ext_conf_builder.rb:39: warning: Tempfile#unlink or delete called on open file; ignoring Gem::Ext::BuildError: ERROR: Failed to build gem native extension. C:/jruby-9.0.0.0/bin/jruby.exe -r ./siteconf20160621-9244-az7xx.rb extconf.rb NotImplementedError: C extensions are not supported <top> at C:/jruby-9.0.0.0/lib/ruby/stdlib/mkmf.rb:1 require at org/jruby/RubyKernel.java:940 (root) at C:/jruby-9.0.0.0/lib/ruby/stdlib/rubygems/core_ext/kernel_require.rb:1 <top> at extconf.rb:1 extconf failed, exit code 1 Gem files will remain installed in C:/jruby-9.0.0.0/lib/ruby/gems/shanetworking/gems/byebug-9.0.5 for inspection. Results logged to C:/jruby-9.0.0.0/lib/ruby/gems/shanetworking/extensions/universal-java-1.8/2.2.0/byebug-9.0.5/gem_make.out Using coffee-script-source 1.10.0 Using thor 0.19.1 Using concurrent-ruby 1.0.2 Using orm_adapter 0.5.0 Using multi_json 1.12.1 Using mimemagic 0.3.0 Installing mysql2 0.4.4 with native extensions C:/jruby-9.0.0.0/lib/ruby/stdlib/rubygems/ext/ext_conf_builder.rb:39: warning: Tempfile#unlink or delete called on open file; ignoring Gem::Ext::BuildError: ERROR: Failed to build gem native extension. C:/jruby-9.0.0.0/bin/jruby.exe -r ./siteconf20160621-9244-13ylh37.rb extconf.rb NotImplementedError: C extensions are not supported <top> at C:/jruby-9.0.0.0/lib/ruby/stdlib/mkmf.rb:1 require at org/jruby/RubyKernel.java:940 (root) at C:/jruby-9.0.0.0/lib/ruby/stdlib/rubygems/core_ext/kernel_require.rb:1 <top> at extconf.rb:2 extconf failed, exit code 1 Gem files will remain installed in C:/jruby-9.0.0.0/lib/ruby/gems/shanetworking/gems/mysql2-0.4.4 for inspection. Results logged to C:/jruby-9.0.0.0/lib/ruby/gems/shanetworking/extensions/universal-java-1.8/2.2.0/mysql2-0.4.4/gem_make.out Using raty_ratings 1.2.0 Using tilt 2.0.5 Using rdoc 4.2.2 Using tzinfo 1.2.2 Using loofah 2.0.3 Using rack-test 0.6.3 Using warden 1.2.6 Using mime-types 3.1 Using autoprefixer-rails 6.3.6.2 Using uglifier 3.0.0 Installing binding_of_caller 0.7.2 with native extensions C:/jruby-9.0.0.0/lib/ruby/stdlib/rubygems/ext/ext_conf_builder.rb:39: warning: Tempfile#unlink or delete called on open file; ignoring Gem::Ext::BuildError: ERROR: Failed to build gem native extension. C:/jruby-9.0.0.0/bin/jruby.exe -r ./siteconf20160621-9244-wni27b.rb extconf.rb NotImplementedError: C extensions are not supported <top> at C:/jruby-9.0.0.0/lib/ruby/stdlib/mkmf.rb:1 require at org/jruby/RubyKernel.java:940 (root) at C:/jruby-9.0.0.0/lib/ruby/stdlib/rubygems/core_ext/kernel_require.rb:1 <top> at extconf.rb:19 extconf failed, exit code 1 Gem files will remain installed in C:/jruby-9.0.0.0/lib/ruby/gems/shanetworking/gems/binding_of_caller-0.7.2 for inspection. Results logged to C:/jruby-9.0.0.0/lib/ruby/gems/shanetworking/extensions/universal-java-1.8/2.2.0/binding_of_caller-0.7.2/gem_make.out An error occurnetworking while installing byebug (9.0.5), and Bundler cannot continue. Make sure that `gem install byebug -v '9.0.5'` succeeds before bundling. 

Esto probablemente no es una solución oficial. Dejé de intentar diferentes cosas, así que terminé reinstalando usando el railsinstaller. Después de volver a configurar todo, puedo bundle install sin errores.