Error de Aptana al comprometerse con el repository git

Estoy usando Aptana 3.0.7 y cada vez que bash enviar cambios al repository de git, recibo este error:

Excepción de bucle de evento no administrado No hay más identificadores [MOZILLA_FIVE_HOME = '/ usr / lib / xulrunner-addons'] (java.lang.UnsatisfiedLinkError: No se pudo cargar la biblioteca SWT. Razones: / home / amir / Desktop / Aptana Studio 3.0.5 / configuration /org.eclipse.osgi/bundles/226/1/.cp/libswt-mozilla-gtk-3659.so: libxpcom.so: no se puede abrir el file de object compartido: No existe ningún file o directory sin swt-mozilla-gtk en java. library.path /tmp/swtlib-32/libswt-mozilla-gtk-3659.so: libxpcom.so: no se puede abrir el file de object compartido: No existe ningún file o directory No se puede cargar la biblioteca: / tmp / swtlib-32 / libswt- mozilla-gtk.so)

seguido de este post:

Se ha producido un error de SWT, se recomienda salir del entorno de trabajo, … etc.

Descargué aptana 3.0.9 pero ocurrió el mismo error.

Este hilo antiguo (2009) mencionó la posibilidad de vincular (enlace simbólico) a las bibliotecas que faltan.
Pero recomendaría primero verificar la versión de xulrunner .

La solución es que Aptana Studio no puede funcionar con la versión de Xulrunner en los repositorys de Arch LinuX porque es demasiado reciente.

En otras palabras, no depende de la versión de Aptana en sí, sino de la versión de un componente externo ( XULrunner ).