Error de actualización de Cocoapods

Extraigo información de github y ejecuto la pod update y obtengo este error:

 Setting up CocoaPods master repo Already up-to-date. [!] The `master` repo requires CocoaPods 0.29.0 - Update CocoaPods, or checkout the appropriate tag in the repo. /Library/Ruby/Gems/2.0.0/gems/claide-0.4.0/lib/claide/command.rb:217:in `rescue in run': undefined method `verbose?' for nil:NilClass (NoMethodError) from /Library/Ruby/Gems/2.0.0/gems/claide-0.4.0/lib/claide/command.rb:210:in `run' from /Library/Ruby/Gems/2.0.0/gems/cocoapods-0.28.0/lib/cocoapods/command.rb:52:in `run' from /Library/Ruby/Gems/2.0.0/gems/cocoapods-0.28.0/bin/pod:24:in `<top (requinetworking)>' from /usr/bin/pod:23:in `load' from /usr/bin/pod:23:in `<main>' 

Editar

Intento sudo gem update esta actualización cocoapods a 0.29. Luego ejecuto la actualización del pod y obtengo:

 Unable to find a specification for `cdebug`. 

Tuve un problema similar. Intente desinstalar CocoaPods e instálelos una vez más. ¡Esto me ayudó y espero que te ayude también!

El solo hecho de ejecutar el command Instalar se actualiza si CocoaPods ya existe:

 sudo gem install cocoapods 

No es necesario desinstalar.

Teniendo en count el comentario de Alexander Kostiev , si quiere o necesita desinstalar versiones anteriores, puede averiguar qué versiones tiene con este command:

 gem list --local | grep cocoapods 

La salida sería algo como esto:

 cocoapods (0.32.1, 0.31.1) cocoapods-core (0.32.1, 0.31.1) cocoapods-downloader (0.5.0, 0.4.1) 

Y elimine uno específico con este command:

 gem uninstall cocoapods -v 0.31.1 gem uninstall cocoapods-core -v 0.31.1 gem uninstall cocoapods-downloader -v 0.4.1