Error al resolver: com.android.support:appcompat-v7:23.4.0

Quiero usar la biblioteca de MusicBobber en mi proyecto, pero apareció este error

Error:Failed to resolve: com.android.support:appcompat-v7:23.4.0 

Tengo com.android.support:appcompat-v7:23.1.1 y este es un file gradle completo:

 apply plugin: 'com.android.application' android { compileSdkVersion 23 buildToolsVersion "23.0.2" defaultConfig { applicationId "com.tabaneshahr.playaudiotest" minSdkVersion 15 targetSdkVersion 23 versionCode 1 versionName "1.0" } repositories { maven { url 'http://repo1.maven.org/maven2' } } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) testCompile 'junit:junit:4.12' compile 'com.android.support:appcompat-v7:23.1.1' compile 'com.cleveroad:audiowidget:0.9.2' } 

Había buscado Stackoverflow pero noté que era útil. ¿que debería hacer? ¿Debe cambiar minSDK ? ¿Debo download algo?

Primero, reemplace su línea de compilation appcompat con la última como esta:

  compile 'com.android.support:appcompat-v7:24.2.0' 

Actualice también a targetSdkVersion 24 .

y elimine la línea de compilation para la biblioteca:

  compile 'com.cleveroad:audiowidget:0.9.2' 

En segundo lugar, limpiar / build y ejecutar el proyecto, no debería recibir ningún error. Si esto sucedió, entonces tu problema no es con el appcompact , sino con la biblioteca.

Thrid, intente agregar la línea de compilation de la biblioteca y de nuevo, y deje que gradle sincronice. Si todavía tiene un problema, le recomiendo que se guarde la molestia e integre la biblioteca en su código manualmente haciendo lo siguiente en este enlace.

¡Espero eso ayude!

Actualice su versión de herramienta de compilation:

  buildToolsVersion "23.0.2" 

a 25 o puede usar

  compile 'com.android.support:appcompat-v7:23.0.0' 

Limpia y reconstruye tu proyecto de Android.

 > create a new project and you will see exact version . 

por ejemplo para mí en el file del proyecto fue:

 compile 'com.android.support:appcompat-v7:24.2.0' 

pero después de crear el nuevo proyecto, vi que es así:

 compile 'com.android.support:appcompat-v7:24.0.0-alpha2' 

tan cambiado y sincronizado y arreglado.