Eliminando libcurl3 en Linux Mint

Recientemente, mi git comenzó a no funcionar y cuando verifiqué el motivo, parece que está relacionado con libcurl3-gnutls y se sugiere degradarlo. Cuando bash instalar una versión anterior, el instalador se queja de que ya tiene una versión posterior en el sistema. Por lo tanto, decidí eliminar la versión anterior primero usando sudo apt-get remove libcurl3-gnutls Sin embargo, recibo una advertencia que me hace pensar dos veces;

 The following packages were automatically installed and are no longer requinetworking: git-man liberror-perl ocl-icd-libopencl1 Use 'apt-get autoremove' to remove them. The following packages will be REMOVED: apt-transport-https brasero brasero-cdrkit evolution-data-server gir1.2-gdata-0.0 gir1.2-totem-1.0 gir1.2-totem-plparser-1.0 git gstreamer0.10-plugins-bad gstreamer1.0-plugins-bad kdepim-runtime kerneloops-daemon libbrasero-media3-1 libcmis-0.4-4 libcurl3-gnutls libgdata13 libgrilo-0.2-1 libkolab0 libkolabxml1 liboauth0 libquvi7 libraptor2-0 librasqal3 librdf0 libreoffice-base-core libreoffice-base-drivers libreoffice-calc libreoffice-core libreoffice-draw libreoffice-gnome libreoffice-gtk libreoffice-help-en-us libreoffice-impress libreoffice-math libreoffice-ogltrans libreoffice-pdfimport libreoffice-presentation-minimizer libreoffice-sdbc-hsqldb libreoffice-writer libslv2-9 libtotem-plparser18 libtotem0 mint-meta-cinnamon mint-meta-codecs mint-meta-core mintsources python-pycurl python3-pycurl python3-uno thin-client-config-agent totem totem-mozilla totem-plugins totem-plugins-extra transmission-gtk WARNING: The following essential packages will be removed. This should NOT be done unless you know exactly what you are doing! mintsources python-pycurl (due to mintsources) 0 upgraded, 0 newly installed, 55 to remove and 53 not upgraded. After this operation, 297 MB disk space will be freed. You are about to do something potentially harmful. To continue type in the phrase 'Yes, do as I say!' 

¿Alguna recomendación sobre cómo proceder?

Como se recomienda en " ¿Cómo fuerzo mi sistema Debian para actualizar GnuTLS? ", Una forma sería:

  • no desinstalar
  • actualizar en su lugar

Es decir:

 apt-get update; apt-cache policy libgnutls26 apt-get update; apt-cache policy libgnutls27