El server sigue pidiendo una contraseña después de que agregué mi key a Bitbucket

He buscado dejar de fumar un poco y encontré algunos temas similares , pero ninguna solución funciona para mí

Tengo algunos repositorys en Bitbucket, algunos privados y otros en equipos. Creé un nuevo repository (webroot) con un equipo (nskiv) como propietario. git remote add origin git@bitbucket.org:nskiv/webroot.git este local con git remote add origin git@bitbucket.org:nskiv/webroot.git

He agregado algunos files y los he enviado al repository. Luego me conecto a mi server y cuando bash extraerlo constantemente tengo que ingresar mi contraseña. Cuando lo hago funciona bien, pero es molesto e innecesario.

Lo extraño es que no uso el enlace HTTPS. Mi .git/config local se ve así:

 [core] repositoryformatversion = 0 filemode = true bare = false logallrefupdates = true ignorecase = true precomposeunicode = true [remote "origin"] url = git@bitbucket.org:nskiv/webroot.git fetch = +refs/heads/*:refs/remotes/origin/* [branch "master"] remote = origin merge = refs/heads/master 

En mi server, he iniciado session con mi nombre de usuario (maurice) y cat /home/maurice/.ssh/id_rsa.pub | pbcopy copydo ( cat /home/maurice/.ssh/id_rsa.pub | pbcopy ) mi key para la configuration de key SSH del equipo.

Cuando bash clonar el repository ( git clone git@bitbucket.org:nskiv/webroot.git ), git clone git@bitbucket.org:nskiv/webroot.git ingresar mi contraseña. ¿Pero por qué?

Editar:

La solución fue activar el agente ssh con eval "$(ssh-agent -s)" Un paso olvidé configurar mi server

Probablemente la respuesta es que no tiene un agente SSH en ejecución. Seguiría estos pasos y me aseguraré de que tenga un agente SSH ejecutándose y de que haya agregado su key.