El package Composer no se encuentra en ninguna versión

Intento crear un package de proveedor personalizado pero aún no he puesto el package en packagist. De acuerdo con los documentos, el package se puede cargar desde git (vcs) en lugar de packagist: https://getcomposer.org/doc/05-repositories.md#loading-a-package-from-a-vcs-repository

El proyecto yii2 (aunque no creo que el framework sea importante) he creado un package dentro de la carpeta del proveedor:

foundationize / yii2-foundation (la estructura de la carpeta es como la de arriba, he comprobado cuádruple).

Mi raíz public_html / composer.json tiene las siguientes inputs:

"minimum-stability": "dev", "require": { "php": ">=5.4.0", "yiisoft/yii2": ">=2.0.5", "yiisoft/yii2-swiftmailer": "*", "foundationize/yii2-foundation": "dev-master" }, 

Mi file de compositor de package, vendor / foundationize / yii2-foundation / composer.json se ve así:

 { "name": "foundationize/yii2-foundation", "description": "The Foundation extension for the Yii2 framework", "keywords": ["yii2", "foundation"], "type": "yii2-extension", "license": "BSD-3-Clause", "support": { "issues": "https://github.com/foundationize/yii2-foundation/issues", "wiki": "https://github.com/foundationize/yii2-foundation/wiki", "source": "https://github.com/foundationize/yii2-foundation.git" }, "authors": [ { "name": "gvanto", "email": "gvanto@hotmail.com", "homepage": "http://foundationize.com" } ], "require": { "yiisoft/yii2": "*" }, "autoload": { "psr-4": { "foundationize\\foundation\\": "" } }, "repositories": [ { "packagist": false, "type": "vcs", "url": "https://github.com/foundationize/yii2-foundation.git" } ] } 

Cuando ejecuto la installation (o actualización) del compositor, sigo recibiendo el siguiente error:

Sus requisitos no se pudieron resolver en un set de packages instalable.

Problema 1: el package solicitado foundationize / yii2-foundation no se pudo encontrar en ninguna versión, puede haber un error tipográfico en el nombre del package.

Causas posibles: – Un error tipográfico en el nombre del package – El package no está disponible en una versión lo suficientemente estable de acuerdo con su configuration de estabilidad mínima, consulte https://groups.google.com/d/topic/composer-dev/_g3ASeIFlrc/ discusión para más detalles.

Lea https://getcomposer.org/doc/articles/troubleshooting.md para conocer otros problemas comunes.

Lo busqué en alta y baja, lea los documentos parece que no funciona (siempre el mismo error, que en realidad creo que sería más útil si dijera que no se encontró el package O que se encontró la versión incorrecta del package) )

¿Me estoy perdiendo algo básico? 🙁

ayuda mucho gvanto apreciado

Debe agregar la input de repositories a su file root composer.json . De lo contrario, Composer no sabe dónde search tu package.