¡El blog de Octopress implementando el rake de error abortado! No hay tal file o directory – git remote -v '

Instalé octopress en mi windows (windows8 x64) con éxito, luego creé un repository llamado wenliangcan.github.com e intenté implementar un blog en github.

Cuando rake setup_github_pages el command rake setup_github_pages e ingreso la url del repository , me da un error:

 rake aborted! No such file or directory - git remote -v 

Antes de ingresar a la url del repository , me da un ejemplo como este:

 Enter the read/write url for your repository (For example, 'git@github.com:your_username/your_username.github.com) 

Mientras que algunos ejemplos de tutoriales de terceros como esta forma:

 git@github.com:your_username/your_username.github.com.git 

Los había probado a los dos, pero me da el mismo error.

Aquí está la captura de pantalla de CMD:

enter image description here

El contenido de la captura de pantalla:

 D:\Profiles\GitHub\Octopress>rake setup_github_pages Enter the read/write url for your repository (For example, 'git@github.com:your_username/your_username.github.com) Repository url: git@github.com:wenLiangcan/wenliangcan.github.com.git rake aborted! No such file or directory - git remote -v Tasks: TOP => setup_github_pages (See full trace by running task with --trace) D:\Profiles\GitHub\Octopress>rake setup_github_pages Enter the read/write url for your repository (For example, 'git@github.com:your_username/your_username.github.com) Repository url: git@github.com:wenLiangcan/wenliangcan.github.com rake aborted! No such file or directory - git remote -v Tasks: TOP => setup_github_pages (See full trace by running task with --trace) 

¿Cómo podría resolver este problema?

¡Gracias!

  No such file or directory - git remote -v 

Eso significaría que su script de ruby ​​no encuentra git en la ejecución actual de PATH (un poco como en este tema ), o el script de rake de alguna manera fuerza establecer su propia RUTA.
Por lo tanto, asegúrese de que la RUTA sea correcta al iniciar el command de rastreo: consulte " Ningún file o directory – git ls-files – WINDOWS " como ilustración concreta.

el otro problema podría ser una cuestión de versión de Ruby (1.9.2 funcionando, 1.9.3 no funciona) en Window7 (ver " Instalación en Windows 7 – falla de segmentación al ejecutar" rake db: migrate " ")